Jump to content
Corsair Community

H80i v2 doesn't show up in Corsair Link


lastation4
 Share

Recommended Posts

SO my H80i v2 was working in Corsair link last night, no problems, but when I booted it up this morning nothing showed up. I hunted around and found that the service wouldn't start, stating that there was some issue with a "quota violation" I've tried reinstalling pretty much everything, including doing a Windows restore, and it still refuses to show up in the software. However, it DOES show up in Device Manager.
Link to comment
Share on other sites

First, make sure that you have the latest version installed.

And can you provide more detail about this "quota violation" ... the exact error message or an event log entry would be good. A quota violation would come from the operating system and I'm really curious what kind of quota violation there would be.

Link to comment
Share on other sites

Looks like the message got truncated. This happened before and after a fresh reset version of Windows 10 if that helps any.

 

Service cannot be started. System.TypeInitializationException: The type initializer for 'Nested' threw an exception. ---> System.Management.ManagementException: Quota violation 
  at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)
  at System.Management.ManagementEventWatcher.Start()
  at System.Reactive.Management.Instrumentation.EventProvider.<>c__DisplayClass6`1.<Receive>b__3(IObserver`1 obs)
  at System.Reactive.Linq.QueryLanguage.<>c__DisplayClass1ea`1.<Create>b__1e9(IObserver`1 o)
  at System.Reactive.AnonymousObservable`1.SubscribeCore(IObserver`1 observer)
  at System.Reactive.ObservableBase`1.ScheduledSubscribe(IScheduler _, AutoDetachObserver`1 autoDetachObserver)
--- End of stack trace from previous location where exception was thrown ---
  at System.Reactive.PlatformServices.ExceptionServicesImpl.Rethrow(Exception exception)
  at System.Reactive.Stubs.<.cctor>b__1(Exception ex)
  at System.Reactive.AnonymousObserver`1.OnErrorCore(Exception error)
  at System.Re...

Link to comment
Share on other sites

What did you set it to? And did you restart afterwards to apply the changes?

Another question ... did you install and/or update anything new before this started happening? Anything at all, even if you think it's unrelated?

 

Unfortunately, this is something going on with a Windows Service called Windows Management Instrumentation (WMI). It's a system service that allows applications to do management stuff ... like enumerate devices and get notification of sleep. Now, I know that the Link service is using this for sleep notification and I strongly suspect that it's also using it to find the devices that are installed (that would make sense). Neither of these is all that intense, crazy or out of the norm and the issue you're seeing isn't common either, at least not on the forum.

Take a look at this as well: https://blogs.technet.microsoft.com/askperf/2014/08/08/wmi-common-symptoms-and-errors/ and see if there are any of the associated other events in your event log that are described here.

It's possible that you have WMI repository corruption but before we go down that path, let's exhaust other options.

Link to comment
Share on other sites

Set it to the max recommended, 107 something or other; yes I restarted. Again, this happened both on my previous system, and when I reset Windows, with its built in reset command. I assumed that resetting Windows would fix this issue.

 

Reading through that article, it doesn't seem like there are any other related errors in the Application log, just a ton of the same error I've been getting about WMI Quota.

Link to comment
Share on other sites

OK ... that tells us that it's likely a memory quota violation. According to the TechNet blog article, the handle quota event would log.

Can you run MSInfo? How about any of the other troubleshooting steps?

There's a bunch of references links in the previous link, including this one: https://blogs.technet.microsoft.com/askperf/2008/09/16/memory-and-handle-quotas-in-the-wmi-provider-service/

Not trying to blow you off but you might also find some good information on the TechNet forums as this is definitely a WMI error. It's manifesting it in Link and may also manifest itself in other apps ... but the root of it is WMI.

Finally ... there's also this: https://blogs.technet.microsoft.com/askperf/2014/08/08/wmi-repository-corruption-or-not/.

Link to comment
Share on other sites

Can you post your system info and OS details? And the quota information (like mine)?

Are you running any other monitoring software at all?

I'm afraid I can't help you any more at the moment but I'm hoping that the Corsair folks may be able to help out. And that info will be needed.

Sorry dude. :(:

Link to comment
Share on other sites

 Share

×
×
  • Create New...