Jump to content
Corsair Community

Corsair Hydro Series H100i GTX Runs hot


RiceBall
 Share

Recommended Posts

Hi,

 

so I've been dealing with high temperatures for 3 years now.

 

Initially when I bought this AIO heatsink, it was to solve overheating issues with my previous CPU which had stock intel heatsink.

I had an MSI gaming motherboard with an i7 4770K.

I had 16 gigabits of ram upgraded to 32 GB at that time, I forgot what model specifically but they were RipJaws.

I have 2 MSI Geforce GTX 980 SLI.

 

Recently this November I upgraded my motherboard, CPU and Ram:

i7-7700k.

Asus ROG Strix Z270E

G.Skill TridentZ DDR4 3000 16gb.

I thought that this might help, it did not.

 

So the issue is: the CPU heats up rapidly, every time when I try to do anything gaming or sometimes even just watching videos on internet, updates? forget about it. The fans would rev up to max right away.

after about 2 years, the stock fans that came with the cooler started making grinding noises, so I replaced them with Noctua NF-F12 iPPC-3000 PWM Fans. upgraded CPU, Motherboard and Fan this November. The heat sink remains the sole issue.

corsair link shows that the temperatures idle at around the high 52 - 57 Degrees C. and when I game, it goes crazy from 70 Degrees to 80 degrees C, at one point it reached and stayed at 100 degrees C.

I've tried reapplying the thermal grease a bunch of times, replaced the fans with more powerful fans. doesn't work.

It feels like the pump isn't working correctly. Corsair link is saying that it IS pumping liquid. So my suspicion is that there might be bits inside the tubes. it'll cycle around get clogged a bit and that's when temperatures start raising, pressure builds up and the clog breaks loose, temperature starts dropping but not fast enough for the bits to cycle and repeat again.

 

I bought the AIO at 11/24/2015.

 

can i still RMA this? if so how and where do i start??

Edited by RiceBall
Link to comment
Share on other sites

 Share

×
×
  • Create New...