Jump to content
Corsair Community

Number row doesn't work


Seawinkle
 Share

Recommended Posts

[Figured out the issue, cable is doing something weird and screws with the num-row when angled downwards directly out of the board]

 

Just got the board in today and am really disappointed that everything form the tilde key to the hyphen does not work 99 percent [i can't use the percentage or standard parenthesis haha] of the time, and when they do work, they're not actually working, they're causing random keys on the row to spam until I press something on the numpad????

 

Let me see if I can get anything

 

45555555555555555555555555555555555555555555555555555555555555555555555555555555555554

 

Yeah, best I could do haha.544444444444444444444444444444444444444444444444444444474 WHY

 

Okay but yeah this is obnoxious, and goes three for three corsair products I've had a bad experience with, which sucks, because I really like the typing experience [the browns]1, and8 have never really used a mechanical keyboard before.ddd4dddddddd5dd450ddddddd781234560-`d okay that's weird. If I hit the keys hard enough [which i`s to say not very hard] the number row ke890---------------------------------------4 keys will spam

 

Seriously not trying to be funny here, but if there's a fix that doesn't involve me sending the board back to the seller and buying a ten dollar walmart keyboard instead2, because they're less hassle, I'd really, really appreciate it.

Edited by Seawinkle
Link to comment
Share on other sites

Are you able to test the keyboard on another computer? Does the keyboard work fine?

 

Put the keyboard into BIOS mode and see whether the spam still occurs. To enter BIOS mode, Press the F1 key followed by the Windows lock key. The scroll lock LED will start flashing which will indicate BIOS mode.

 

 

Exiting BIOS mode is the same key combination.

Link to comment
Share on other sites

Are you able to test the keyboard on another computer? Does the keyboard work fine?

 

Put the keyboard into BIOS mode and see whether the spam still occurs. To enter BIOS mode, Press the F1 key followed by the Windows lock key. The scroll lock LED will start flashing which will indicate BIOS mode.

 

 

Exiting BIOS mode is the same key combination.

 

I did try it on a different computer, and had the same issue, although, the bios mode thing actually worked! Doesn't happen anymore, in or out of bios mode. That's really weird. Like, why would hitting random keys hard enough trigger the number row keys? I don't know what I did to make that happen, or if it just happened on its own. Huh. I uninstalled the drivers, reinstalled, updated firmware and etc., there should probably be a factory default setting in the cue2 software that would help with this thing in the future.

 

Well anyway, thank you very much! I was just about to mail it back for a refund, but I'll hold out on that for a few days and see if the problem pops back up, and if not, will hold onto it. Appreciated, friend!

Link to comment
Share on other sites

Sorry for the double-post, a bit after the issue was seemingly fixed, it cropped up again, and switching to bios mode didn't fix it, but it seems fine again now even though I haven't done anything to fix it? If anybody could advise a fix, given that it does definitely seem to be some kind of firmware/software issue, I'd appreciate it. I've still got a while before I have to send it back for a refund, so if I can get it to the point I'm not having issues that'd be cool I guess.
Link to comment
Share on other sites

TRIPLE POST, but, I identified the issue. It would seem the number row begins acting out if I kick out the stands and elevate it, and the issue occurs immediately If I pick the keyboard up and hold it horizontally, keys facing me. I'm getting used to and enjoy the feel, so I'm gonna order a new one soon and send this one back once the replacement is in for my refund, I guess!

 

Edit: Even simpler than that, looks like the cable is the culprit. If it's being pulled down at all, like it is when I lift it up, the spam starts, otherwise it's straight/up-angled and works fine. Good to know the exact culprit, hope Corsair can better QC for this kinda thing, even if it is unlikely to happen often.

Edited by Seawinkle
Link to comment
Share on other sites

I can confirm this, since mine starting doing this a week ago. I tried everything, and nothing would work. I did the bios menu, forced a firmware update, uninstalled drivers, made sure the software was up to date, restarted my computer countless times and NOTHING. Low and behold, it's the cord, of all things. Not sure how I will fix mine. Not being able to use my number row and special characters bite.
Link to comment
Share on other sites

  • 2 months later...
 Share

×
×
  • Create New...