Jump to content
Corsair Community

Corsair H50 radiator/fan loud whirring noise


Granty
 Share

Recommended Posts

Edit: Sorry Its the H55 not 50.

 

Earlier today my PC (Which I brought second hand around 2 weeks ago) all of a sudden began making quite a loud whiiring noise, I immediately switched it off but I noticed it seemed to be coming from the fan/radiator on the H55? (which is attached to the GPU MSI 1070 with the Kraken G10 bracket) When I later switched the PC back on there seemed to be no issues but after a couple of hours of idling it did it again, this time I checked and it is almost certainly the cooler, I left it this time and after about 8-9 seconds it went reasonably quiet again?

Would anybody have any advice on what the problem may be.

Could it just be the fan running out of Sync?

The GPU that it is attached to has held a steady temp at around 28-30C throughout the day.

All help greatly appreciated

Edited by Granty
Link to comment
Share on other sites

Still the same basic question as to whether this was the pump or fan noise. The H55 Pump is high speed with a high, but faint pitch. You should not be able to easily pick it out, thus the pump as the source would be concerning.

 

Fan is more likely. Since it seems infrequent, it will be hard to catch it in the act. What are you using as the control variable for the H55 fan since it is own GPU duty? Or is it hooked into the GPU circuit board?

Link to comment
Share on other sites

 Share

×
×
  • Create New...