Jump to content
Corsair Community

failed to install Corsair Link


ohhkarma
 Share

Recommended Posts

Hi, I opened Link and had a popup for an update so I downloaded it and it came up with the error below, so I've gone ahead and deleted everything related to Corsair Link and downloaded it and tried to install, it failed again.

 

I've now gone ahead and used the older version I had but now that has failed to install, suggestions?

 

tIuNngd.png

Link to comment
Share on other sites

So ...

when you install a program, Windows keeps the MSI (Microsoft Installer) in a Package Cache ... so you don't have to scramble to find the CD/DVD/File to uninstall it. As a part of the upgrade process, Link will uninstall the previous version rather than attempting to "patch" an existing installation. Both are options with MSI but, in all honesty, patch MSIs (or MSPs) are a royal pain in the backside and it's typically easier and more reliable to uninstall and reinstall. If, however, Windows cannot find the cached MSI file, you'll get this error.

The solution would be to get the previous version MSI. You may be able to run from the MSI of the installed version and uninstall that way (that should work; haven't tried it but it jives with how MSI works), you can put it in the location that Windows is looking for it or you can use the Browse button to tell Windows where the MSI file is located.

 

Did you delete your package cache? Or do you have a "Sweeper" utility that may have done this?

Link to comment
Share on other sites

 Share

×
×
  • Create New...