Jump to content
Corsair Community

Corsair ssd toolbox wont load


Recommended Posts

I have 3 corsair ssd drives in a raid 0 array on windows 10 64bit. I am experiencing intermittent 100% loads on the disk array while windows performance graph says there is no disk activity. the system hangs for several seconds, often crashes 3d games if they are running.


Looking through the forum there appears to be 2 solutions.

1. disable ahci but lose native command queuing and power saving features

2. update the ssd drives firmware


I have opted to try the second route.


after installing the corsair ssd toolbox it would not run. thinking I may need a reset I tried that. still wouldn't load. looking in task manager I see the corsair ssd toolbox service process and user interface (32 bit) process running.


I try to end their tasks to start them again. the user interface one exits successfully but the service does not. I try to restart the application anyways and the user interface comes back in the process list but still no gui or anything loading. then I tried Taskkill /IM CSSDT.exe /F after following the service process to it's executable but cmd.exe (running as administrator) said it wasn't running. using task manager to end the process tree leads to access denied.


at this point I tried to reinstall but and reset, but it's the same. the processes show up but there is no window or taskbar icon or any signal that it's running other than in task manager.



How do I proceed to update the firmware on my ssd drives?

Link to comment
Share on other sites

OK so here is the story.

3x corsair force 3 gt drives in a raid 0 as my windows drive.


Corsair toolbox wouldnt load no matter what I would do.

couldn't try it in ahci mode because then I don't have a windows to boot into.


found vic files on this forum but there wasn't a lot of description of which of the 3 in the zip I should use with my drive and it required the old corsair firmware updater

found old versions of corsair firmware updater based on the sandforce tools on some sketchy russian website.

corsair firmware updater didn't see my drives either.


found the original sandforce firmware updater of similar sketchy russian site and same thing. it wouldn't see my drives.


I dual boot linux on a 960 pro nvme drive so I tried sandforce updater for linux. it didnt see my drives even in ahci mode in the bios.

work around on this forum was to put your storage controller into ahci mode.

my storage controller was already in ahci mode even though the drives showed up with ata- in the beginning of their description which I thought was old parallel attached something something terminology from the days of ide.


tried the corsair firmware updater and corsair ssd toolbox in linux under wine. wine reported that the command to talk to the drives hadn't been implemented yet so the gui came up but it wouldn't detect the drives either.



getting desperate I tried to install a new copy of windows on my 2tb hybrid drive.

windows installer said it couldn't install to that type of hard drive in efi mode so I would have to format and lose 1tb of my data.


then I heard about winpe a bootable windows that is used to run certain tools on your computer when you can't boot. made my own winpe image, flashed it to a usb flash drive. found out they don't include the regular windows gui support into that tool so it was another dead end.


then I went searching my basement and found an old crusty 120gb sata drive. i plugged it in, formatted it and tried to install windows on it. it would get 94% done and then report an error having to do with not being able to store locale information on and would quit. I tried this 3 times just to make sure.


so I thought my windows 10 iso was corrupt so I redownloaded it. same error in the same place.


so then I tried to download a fresh windows 10 iso that was a slightly older version and that iso failed installing at a different point.

No errors were found on the drive by windows, but I'm betting it's because of this hard drives age and the fact that it's been in my basement for over a decade.


finally i found that I could make a real bootable windows on a flash drive with a program called wintousb


I tried installing windows to it and it took several hours despite the fact that my 64gb flash drive was fairly fast for a usb 2.0 device.


I got into this bootable windows. it was so slow that it took me another hour just to get IE/EDGE to navigate to corsair's site, download corsair ssd toolbox, and install it.


I ran it and it recognized my drives!

firmware updated!


rebooted, put drives back into raid, changed boot device to raid device, and no data loss.


It's only been maybe a day but I haven't seen the 100% disk usage yet when it used to happen every hour or two! Sometimes it would be stable for about this long so I'm still crossing my fingers that this did in fact fix it but I think I'm in the clear.


I hope this helps someone else that's in the same boat as me.

Edited by sirus20x6
Link to comment
Share on other sites

  • 1 year later...

  • Create New...