Jump to content
Corsair Community

Corsair Strafe Keyboard Disconnecting/Power Problems


davezeb
 Share

Recommended Posts

This is the Strafe MX Silent version.

 

I just purchased a new computer, Dell 5675 with Ryzen 7 1800.

 

Often, the keyboard when plugged will in work fine for a few minutes. Then almost as if it were running on battery and not USB, the lights will dim, flicker and then I will hear Windows 10 go through a connecting, disconnecting, reconnecting maybe 2-3 times. Then all lights go off and the keyboard is a good as dead for a time.

 

Sometimes when I wait a few minutes, plugging it into a different USB port, it will light up, but not the usual Orange, rather a dull and dim flickering blue and will not be recognized by the OS. Sometimes it will be recognized but for only a few seconds, then quickly disappear, and quickly will the lights go out and it is as dead again.

 

I finally had the keyboard up and running for about a week (had not turned off computer in this time, only restarts and sleep mode), and I had disabled power management of USB devices and controllers, also in HID, unchecking the box that allowed them to turn off devices to save power. That seemed to have done the trick, and I thought I had resolved this.

 

However, last night I powered the computer off and when turned back on this morning, no keyboard lights at all, just dead.

 

I should note that I do have another USB keyboard, a standard Dell keyboard that came with the box and it works flawlessly all the time.

 

I have tried both soft and hard reset of the strafe (escape key and button on underside) and have not been able to get this thing worked out.

 

To me it's all a bit strange, but what else is new with computers. I understand it could be a faulty keyboard, but my instinct tells me it is a PC environment variable and not hardware. So far as I know, the keyboard contains no onboard battery, and yet all the symptoms play out exactly as if it were on battery and running dry. This leads me to look rather to the system. The Strafe keyboard also has a different connector, I imagine, in terms of how it draws power, etc through the port than the Dell KB… but I am guessing here, unfamiliar with this depth of hardware/power interaction with the Mainboard through USB 2.0 or 3.0.

 

I am hoping someone will recognize this as a simple setting somewhere and be able to provide a solution. Sorry for the long post, but figured I'd give as much relevant info as I could.

 

Thanks!

 

(Oh, btw, checked BIOS and there really isn't much to work with. Simply on or off with regard to USB ports.)

 

Oh, I have also tried the KB in all ports, both 2.0 and 3.0, both with and without pass-through also plugged in. Interestingly, when the KB goes dead in 1 port, it won't pick back up in that port until after restart or long wait, but others may pick it up for a brief time.

Link to comment
Share on other sites

Ok, this may or may not be relevant but I'll post what my problem was and how I fixed it.

 

Recently I updated CUE and began having problems. I never attributed the update as being the problem as it seemed to be more hardware as software related.

 

What was happening was I couldn't turn on the computer via the power button. It would click, the lights would flash on and the first code would flash on the Q-code LED, then it would just die. The only way to get it to turn on was to turn it off at the power supply for 30 seconds, then turn it on with the 'start' switch on the actual board itself (ASUS Ranger VII).

 

After a week or so of this nonsense I started looking for solutions. Tried bridging the power connectors on the board to simulate it powering on in order to rule out the front panel button being the problem. It wasn't.

Tried swapping the power button and reset connectors on the board-same thing happening.

 

Tried for the hell of it enabling KeyBot and suddenly it was booting up no problem.

 

So, what is KeyBot? Well, it's an inbuilt function on the board that allows you to program keys to perform other functions. You turn it on, reprogram your keyboard.

Sounds familiar huh? Reprogrammable keys...I wonder what else does that.

 

So, now I had it booting again, I checked CUE for an update, which there was. Installed it, booted up and the problem happened again, only this time the fix was to disable KeyBot. Eureka!

 

Basically, my computer was in conflict about what was in charge of reprogramming the keys and as the keyboard check is one of the first things done this conflict 'broke' my computer.

 

Anyway, hope this helps.

 

Jim

Edited by jim42
Link to comment
Share on other sites

 Share

×
×
  • Create New...