Jump to content
Corsair Community

H100i v2 [USB] not working properly


Rauss
 Share

Recommended Posts

Hi Guys, I'm new to this forum and just recently purchased H100i v2.

 

So I'm having a bit trouble here with my H100i v2 as the device was recognized by the device manager but with status as I quoted below:

 

"Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"

 

Which in result, the H100i v2 was not detected by Corsair Link. I tried to look-up to the registry where H100i v2 USB was located and tried to look at the Device Parameters to see whether there's any fix I can make, however, the Device Parameters was empty. Nothing. Just (Default) with value not set.

 

I tried the SIV as well, looking up to USB Bus, and the H100i v2 was detected but the Device Information says "I/O Error 31 A device attached to the system is not functioning".

 

Anyone else experienced same problems and found a fix? Any help will be much appreciated.

 

Btw, the fans are working just fine. I can configure the fans from the BIOS.

My specs are (if relevant):

MB: Asus Z170 Pro Gaming Aura

GPU: Palit Gamerock GTX 1070 8GB

CPU: i5 6600k

 

[uPDATE]

The problem was fixed using older Corsair Link. But, I'm still curious why the latest Corsair Link software was causing the trouble....

 

[uPDATE 2]

Referring to replies below, was suggested to look more at the forums and solved! :D

Edited by Rauss
Link to comment
Share on other sites

 Share

×
×
  • Create New...