Jump to content
Corsair Community

Corsair Link Service - Auto Start


DevBiker
 Share

Recommended Posts

Is anyone aware of any reason why the Corsair Link Service should not be set to "Automatic" startup (rather than "Manual")?

Corsair Folks: Is there a reason why this can't be set at installation time? Or is it but since I've been running Link for a while it didn't get updated with new versions? I'd, personally, rather not run the Link GUI if I don't need to be changing my settings (LED, fan curve, etc.) as I do my monitoring with other software that is more detailed (HWInfo).

Link to comment
Share on other sites

I'm curious why not ... I currently have mine set to Autostart and it seems, so far, to be working fine ... it appears to set my custom fan curve and LED. Now ... if I open Corsair Link to change settings, it stops the service when it's done (annoying). But that's easily fixed.

I totally get the desire to simplify and stabilize the software and, I would think, that not requiring a WPF app to be running for the functionality to set LEDs and fan curves would actually be a step in that direction. I've done a goodly bit of WPF work in my time and, while it's wonderful and does make for some pretty apps, it's also pretty persnickety at times, can hog system resources and do some generally very strange stuff, some of which totally depends on the exact combination of OS, Service Pack and NetFX patch level. :brick: But ... that's just my opinion from a distance; I'm sure that there are many things that I'm not aware of that are concerns for y'all. But hey ... if it's easy to make this a supported scenario, I'd certainly appreciate it. And I'm happy to be a guinea pig.

Link to comment
Share on other sites

Actually, the more that I think about this the more I think that it's actually quite important for the Link Service to be able to start and set profiles automatically. While that's probably not as big a deal on my personal system as I work on it all day long ... with the exception of the resources that it takes ... I also have another H100i v2 on my home media server. Now, that's a headless server and I don't log in to it often (server ... right?) but I would like to make sure that I can set my custom fan profile on that without needing to log in to it. While the quiet profile is probably OK most of the time, there are occasions where this server will be doing transcoding of multiple media streams and that can keep the CPU spiked for quite some time.
Link to comment
Share on other sites

It does ... until you do a power off and then reboot. Which, honestly, I don't do very often on that server (typically only when installing something). Which would also be one of the few times that I'd actually log in to that machine.

Still ... for me, at least, IMHO, it'd be nice to have. ;-) And the Link app wouldn't need to run as "Admin" ...

Link to comment
Share on other sites

 Share

×
×
  • Create New...