Jump to content
Corsair Community

K55 Keyboard acting up


Enigma776
 Share

Recommended Posts

Hello,

 

I (probably a mistake) updated the firmware on my K55 RGB keyboard to the latest firmware and now when the computer comes out of standby cue fails to recognise the keyboard until I unplug and plug it back in again, I have installed a new MM800 mouse pad today but I think its the firmware that has screwed me as everything else works fine including my mouse (Sabre RGB)

 

Anyway of downgrading the firmware?

Link to comment
Share on other sites

  • 3 months later...

Hey there,

 

Today I also received a Corsair K55. I'm amazed by the software that comes with it, and the fixes I see that it gets when people report bugs, my gratefulness for that!

 

I too however have the problem that after coming out of standby, the system does not recognize the keyboard anymore. I have to unplug and plug it back in to work again.

 

What is going wrong here?

 

I tried different USB ports on the back of my computer, thought it did work a few times with a different port but now it doesn't work with the port that did work before.

 

I read here and then on the forum this is a known bug. I do hope there is a fix for this, or a fix in the make :).

 

My specs:

Windows 10

MSI H110M ECO

Corsair K55 RGB (firmware v.30.06)

Harpoon RGB Mouse

 

The mouse keeps working anyway :).

 

Thanks for any help!

Link to comment
Share on other sites

I have had several annoying issues with my K55 and it's a little over a month old - all related to the Corsair software/drivers, including not being able to use ANY USB controller, not matter where I plug it in (including a powered USB hub), if the CUE software/keyboard HID drivers are enabled - it's not a Steam-specific issue as they contend, as it occurs even in non-Steam game with the drivers and CUE running, the second you disable those the controllers suddenly work. So if I want to use controllers without them not working/cutting out etc. I have to basically either unplug my keyboard before playing or disable all extra functionality and lose custom keyboard/mouse lighting and macros etc. - far from ideal.
Link to comment
Share on other sites

  • 4 months later...

THOUGHT IT WAS SOLVED: I use an MSI H110m ECO motherboard. I updated the BIOS which had the following description:

- Improve USB 2.0 device can not work properly after resume from S3 mode.

 

I thought updating the BIOS fixed it.

 

Update: No it did not fix it, just the first times getting out of standby, after that the bug gets back :(

Edited by MiiChiel
Link to comment
Share on other sites

 Share

×
×
  • Create New...