Jump to content
Corsair Community

Corsair LINK 4 service terminated unexpectedly


RedHammer
 Share

Recommended Posts

Messages in event viewer:

 

Faulting application name: CorsairLink4.Service.exe, version: 4.9.0.57, time stamp: 0x59b2d219

Faulting module name: KERNELBASE.dll, version: 10.0.15063.608, time stamp: 0xadaa6ed6

Exception code: 0xe0434352

Fault offset: 0x000eb832

Faulting process id: 0x24f8

Faulting application start time: 0x01d33afc07702db9

Faulting application path: C:\Program Files (x86)\CorsairLink4\CorsairLink4.Service.exe

Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll

Report Id: 3ee13e22-636e-495e-8c58-fac94a01197c

Faulting package full name:

Faulting package-relative application ID:

 

Application: CorsairLink4.Service.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: System.IO.IOException

at System.IO.__Error.WinIOError(Int32, System.String)

at System.IO.FileStream.WriteCore(Byte[], Int32, Int32)

at System.IO.FileStream.FlushWrite(Boolean)

at System.IO.FileStream.Dispose(Boolean)

at System.IO.FileStream.Finalize()

 

The Corsair LINK 4 service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service.

 

I started to notice a while back that I would hear the USB disconnect and reconnect sound in Windows. When this happens the fan ramp up until the service restarts. Happens about every 10 min consistently.

 

I just updated the link software and firmware for the commander pro. Now when I turn my PC on the fans are at a very high rpm until I boot into windows and corsair link loads up. Is this supposed to happen now in the newest version? Any ideas on how I can fix the service restarting?

Link to comment
Share on other sites

A few days ago I built a new system and installed the H110i which comes with a clip on pump for AM4 type motherboards and requires you to plug the USB connector to the motherboard USB 2.0 connector. Win10/64, just as you say, tells me every 10 minutes or so that "my most recently connected USB device has failed" and the fans ramp up for a few seconds and then go back to being quiet. This is on an Asus Crosshair VI Hero motherboard with a Ryzen 1800X CPU on it. I do not have, nor can I find anywhere the Corsair software for this H110i unit and Win10/64 obviously does not recognize it. Since many of you seem to be having the same issue with or without the software, is there some way to tell Windows what the heck the "unrecognized usb device" is and get it to stop disconnecting from and then reinitializing the USB port? Is there an actual viable driver for this pump using the USB 2.0 connector? What are my options? Using other software or the latest bios for the motherboard (vs 1602) the pump seems to be working and the CPU is not overheating so all that is required is to get control of the thing and have some way to report out what is happening in there and let Windows know what the device is.
Link to comment
Share on other sites

I went through and tried some things I've read in other threads so far 0 service crashing today.

 

Uninstalled asus ai suite (Worked fine but just to be sure it wasn't causing conflicts)

 

Uninstalled aura rgb control software (Just used for built in mobo lighting, Didn't work anyways)

 

Looked back to see what the original version of Corsair Link I downloaded (4.8.0.82). I had trouble getting my RGB HD fans to work, Only one would light up. Took a guess as to what version fixed the small issues I was having and ended up with 4.8.2.1. Only issue with this version is the Ryzen temp offset isn't fixed but not a big deal, Just make sure nothing is set to the cpu package group.

 

I messed around with all my corsair devices (psu, AIO water, hd fans, mag lev fans, led strips, All stuffed into the Commander Pro) Settings seem to be working correctly after several warm restarts. If everything works after some cold boots I'd stick with version 4.8.2.1 until things get sorted out. Hope this helps

 

For ref

Commander pro is on firmware 0.3.153

bootloader 0.3

 

H115i firmware 2.8.0.0

Edited by RedHammer
Link to comment
Share on other sites

Same board here with 1700x. My driver is called "Corsair USBxp Driver" version 3.3.0.0 under details it says hydroseries H115i. I'd check to see if you have this as well. Link installs this driver if I'm not mistaken. Try Link version 4.8.2.1 and make sure your fans are set to the H115/H110 group and not the CPU package or fans will go nuts all the time.
Link to comment
Share on other sites

 Share

×
×
  • Create New...