Jump to content
Corsair Community

H100i v2, missing after first reboot Win10


synyster
 Share

Recommended Posts

Installed Latest version of Corsair Link (after restarting win10 in "allow unsigned drivers mode" to stop it blocking the driver)

 

Started CL, worked perfectly. Detected H100i, LED/pump speed customization all worked perfectly.

 

Restarted PC.

 

CL launched at startup.

H100i was missing from CL... Damn :(:

Checked in device manager.

Driver version 3.3.0.0

 

"Corsair USBXp Driver" had a warning icon.

In events: "Device not started (SIUSBXP)"

Device USB\VID_1B1C&PID_0C09\7289_2.0 had a problem starting.

Driver Name: oem27.inf

 

Can even see the previous event where it started perfectly after the install.

 

Tried this entire process a second time with fresh install.

Same result.

 

Any help would be great.

 

Specs:

ASUS z270E mobo

i7700-k

H100i v2

Windows 10 Anniversary

Link to comment
Share on other sites

  • Corsair Employees
Installed Latest version of Corsair Link (after restarting win10 in "allow unsigned drivers mode" to stop it blocking the driver)

 

Started CL, worked perfectly. Detected H100i, LED/pump speed customization all worked perfectly.

 

Restarted PC.

 

CL launched at startup.

H100i was missing from CL... Damn :(:

Checked in device manager.

Driver version 3.3.0.0

 

"Corsair USBXp Driver" had a warning icon.

In events: "Device not started (SIUSBXP)"

Device USB\VID_1B1C&PID_0C09\7289_2.0 had a problem starting.

Driver Name: oem27.inf

 

Can even see the previous event where it started perfectly after the install.

 

Tried this entire process a second time with fresh install.

Same result.

 

Any help would be great.

 

Specs:

ASUS z270E mobo

i7700-k

H100i v2

Windows 10 Anniversary

 

Have you tried removing the device driver and uninstalling CL4 completely? You can then try reinstalling the latest version of CL4 from our website and see if that resolves your problem. Alternatively, check the USB connection between the H100i v2's pump and your motherboard, a bad connection could also be causing this.

Link to comment
Share on other sites

Installed Latest version of Corsair Link (after restarting win10 in "allow unsigned drivers mode" to stop it blocking the driver)

 

Started CL, worked perfectly. Detected H100i, LED/pump speed customization all worked perfectly.

 

Restarted PC.

 

CL launched at startup.

H100i was missing from CL... Damn :(:

Checked in device manager.

Driver version 3.3.0.0

 

"Corsair USBXp Driver" had a warning icon.

In events: "Device not started (SIUSBXP)"

Device USB\VID_1B1C&PID_0C09\7289_2.0 had a problem starting.

Driver Name: oem27.inf

 

Can even see the previous event where it started perfectly after the install.

 

Tried this entire process a second time with fresh install.

Same result.

 

Any help would be great.

 

Specs:

ASUS z270E mobo

i7700-k

H100i v2

Windows 10 Anniversary

 

Funny... i have the exact same pc specs with the same problem... i have the z270F though.

 

if you leave windows in test mode it works perfectly.. soon as i turn test mode off then the driver stops working again.

 

Is there no way corsair can get this driver verified by windows? that would solve everyone's problems.

Link to comment
Share on other sites

Funny... i have the exact same pc specs with the same problem... i have the z270F though.

 

if you leave windows in test mode it works perfectly.. soon as i turn test mode off then the driver stops working again.

 

Is there no way corsair can get this driver verified by windows? that would solve everyone's problems.

 

^this

 

Works perfectly in unsigned driver/test mode. Won't launch the device otherwise.

 

A permanent fix would be good....

Link to comment
Share on other sites

Have you tried removing the device driver and uninstalling CL4 completely? You can then try reinstalling the latest version of CL4 from our website and see if that resolves your problem. Alternatively, check the USB connection between the H100i v2's pump and your motherboard, a bad connection could also be causing this.

 

Tried all this before I posted, seems the unsigned driver device can't launch unless windows is in " allow unsigned drivers" mode. Which you can't even turn on permanently in windows 10 (unlike 7 and 8.1) unless you use your PC in "test mode" 24/7... Which means you can't use your PC for anything pretty much.

 

Any chance that driver could get signed? :laughing: or else I'm pretty much screwed

 

Edit: looks like there is a cmd to manually turn off driver signature enforcement (bcdedit.exe /set nointegritychecks on)

Will check back tomorrow if it works or not.

Edited by synyster
Link to comment
Share on other sites

Tried all this before I posted, seems the unsigned driver device can't launch unless windows is in " allow unsigned drivers" mode. Which you can't even turn on permanently in windows 10 (unlike 7 and 8.1) unless you use your PC in "test mode" 24/7... Which means you can't use your PC for anything pretty much.

 

Any chance that driver could get signed? :laughing: or else I'm pretty much screwed

 

This must be a main stream problem ? i am wondering if this is just effecting the z207 chipset systems?

Link to comment
Share on other sites

This must be a main stream problem ? i am wondering if this is just effecting the z207 chipset systems?

 

Found the fix, finally. Just gonna drop a quick guide here for anyone who comes across this with the same problem like us.

Probably effects all mobos, is harder to fix on ASUS ones because disabling secure boot is a pain.

 

1)Uninstall both the following in programs and features.

Corsair Link 4

Windows Driver Package - Corsair Components

 

2) Uninstall the H100i in device manager. Should be under "other devices" with an error symbol.

 

3) Normal PC restart. Hit F2 on startup for BIOS. Set "Secure Boot" to "Disabled".

For ASUS mobos use this guide, other guides add 5+ unnecessary steps...

https://www.all4os.com/windows/disable-asus-motherboards-uefi-secure-boot.html

 

4) Boot up OS. In Command Prompt (Admin) enter the following.

bcdedit /set nointegritychecks off

and

bcdedit /set testsigning on

 

5) Restart PC for good luck. Install Corsair Link as admin, should install drivers with no errors..

 

Done...

 

Now when your restart/shutdown your PC it should always start the device correctly at startup and display the H100i correctly in CL4.

 

Thank you Corsair, for wasting 4 hours of my life because you didn't bother to get that driver signed. :laughing::laughing::laughing:

 

Peace.

Link to comment
Share on other sites

  • Corsair Employees

The best workaround at the moment is to rollback to a previous version of CL4.

 

Download link for 4.7: http://downloads.corsair.com/download?item=Files/Corsair-Link/Corsair-LINK-Installer-v4.7.0.77.zip

 

Hopefully this helps in the mean time while we get this driver issue resolved.

 

Edit:

 

Here's a direct download for CL4 version 4.8.3.8 which should also work.

http://downloads.corsair.com/download?item=Files/Corsair-Link/Corsair-LINK-Installer-v4.8.3.8.zip

Edited by Corsair CJ
Added direct download link for CL 4.8.3.8
Link to comment
Share on other sites

Found the fix, finally. Just gonna drop a quick guide here for anyone who comes across this with the same problem like us.

Probably effects all mobos, is harder to fix on ASUS ones because disabling secure boot is a pain.

 

1)Uninstall both the following in programs and features.

Corsair Link 4

Windows Driver Package - Corsair Components

 

2) Uninstall the H100i in device manager. Should be under "other devices" with an error symbol.

 

3) Normal PC restart. Hit F2 on startup for BIOS. Set "Secure Boot" to "Disabled".

For ASUS mobos use this guide, other guides add 5+ unnecessary steps...

https://www.all4os.com/windows/disable-asus-motherboards-uefi-secure-boot.html

 

4) Boot up OS. In Command Prompt (Admin) enter the following.

bcdedit /set nointegritychecks off

and

bcdedit /set testsigning on

 

5) Restart PC for good luck. Install Corsair Link as admin, should install drivers with no errors..

 

Done...

 

Now when your restart/shutdown your PC it should always start the device correctly at startup and display the H100i correctly in CL4.

 

Thank you Corsair, for wasting 4 hours of my life because you didn't bother to get that driver signed. :laughing::laughing::laughing:

 

Peace.

 

Well done mate, i actually did try disabling secure boot in bios but dont think i done it correctly.. nice guide.

 

The best workaround at the moment is to rollback to a previous version of CL4.

 

Download link for 4.7: http://downloads.corsair.com/download?item=Files/Corsair-Link/Corsair-LINK-Installer-v4.7.0.77.zip

 

Hopefully this helps in the mean time while we get this driver issue resolved.

 

Edit:

 

Here's a direct download for CL4 version 4.8.3.8 which should also work.

http://downloads.corsair.com/download?item=Files/Corsair-Link/Corsair-LINK-Installer-v4.8.3.8.zip

 

Thanks will try this method first later.

Link to comment
Share on other sites

The best workaround at the moment is to rollback to a previous version of CL4.

 

Download link for 4.7: http://downloads.corsair.com/download?item=Files/Corsair-Link/Corsair-LINK-Installer-v4.7.0.77.zip

 

Hopefully this helps in the mean time while we get this driver issue resolved.

 

Edit:

 

Here's a direct download for CL4 version 4.8.3.8 which should also work.

http://downloads.corsair.com/download?item=Files/Corsair-Link/Corsair-LINK-Installer-v4.8.3.8.zip

 

Just a heads up... 4.8 doesn't work but 4.7 does.

Link to comment
Share on other sites

 Share

×
×
  • Create New...