Jump to content
Corsair Community

Is my H100i V2 done for?


ThatsDirty
 Share

Recommended Posts

So I think my H100i is done for after a year of owning it. Booted it up earlier and got a CPU fan error message in post and went to the BIOS and my BIOS was showing my CPU temps at 75+ and CPU fan showed N/A in. Set my RPM limit to ignore to get into Windows and opened up core temp to see my CPU temps at 90-100 and instantly switched my power switch off. Checked all my connections and tried the CPU_OPT headers to see if anything would happen and was still getting CPU fan error. Also felt the tubes and was getting slight vibrations, not sure if it's vibrations from the pump or from fans, etc.

 

All my inputs and everything looks fine so I'm guessing my cooler gave out? Guess I have to do a RMA?

Link to comment
Share on other sites

It would appear so. If this is a H100i v2, make sure your pump connected header is set to 100% or disabled. If this is the prior H100i with its SATA power connector, you could try another PSU connection point, another SATA connector, or just verify the connection is secure.

 

Both or long shots and not likely to help. The CPU fan error generally means the BIOS no longer sees a device there and something has gone wrong inside the unit. I would start the RMA process from the tech support link at the top of the page.

Edited by c-attack
-ly
Link to comment
Share on other sites

It would appear so. If this is a H100i v2, make sure your pump connected header is set to 100% or disabled. If this is the prior H100i with its SATA power connector, you could try another PSU connection point, another SATA connector, or just verify the connection is secure.

 

Both or long shots and not likely to help. The CPU fan error general means the BIOS no longer sees a device there and something has gone wrong inside the unit. I would start the RMA process from the tech support link at the top of the page.

 

Thanks for your input c-attack, this is a H100i V2, in the ASUS BIOS it's on PWM in Q-Fan Control and set in manual at 100%.

 

Thanks for the help, just put in a ticket. Hope I can get this replaced.

Link to comment
Share on other sites

 Share

×
×
  • Create New...