Jump to content
Corsair Community

Flash Voyager 3.0 64 GB don't format/work anymore


bertrand
 Share

Recommended Posts

Hello everyone,

I have a USB Flash Voyager 3.0 drive, CMFVY3A-64GB, it doesn't work anymore.

Unfortunately I unplugged it too quickly :sigh!:

 

It is recognized under Windows 10 and ubuntu.

I can plug and unplug it but I can't format it and I can't write on it, I tried many things:

 

Under Windows:

- Tried to low format it, doesn't work

- Tried to fix it with the chkdsk command which returns errors:

chkdsk F: /f /r
An unspecified error occurred (696e647863686b2e 4d3).
An unspecified error occurred (6e74667363686b2e 1652)

- Tried the Diskpart command, doesn't work

- Tried the disk manager as well, doesn't work

 

Under ubuntu:

- Tried GParted to format it in FAT32 and NTFS, doesn't work, I get an I/O error

- Tried the commands:

sudo mkfs.vfat -I -F 32 /dev/sdc

and

sudo dosfsck -t -a /dev/sdc

Doesn't work !

 

So my question is:

Will a firmware flash restore my USB drive fully fonctionnal ?

In this case I don't know where to find the right firmware and how to flash the USB key...

 

I used Chip Easy to get more informations about this USB device but I don't know how to use them.

Capacity:  59.6G
Device ID       : VID = 1B1C     PID = 1A03
Device version  : 1100

Device vendor   : Corsair
Device model    : Voyager 3.0
Protocol        : USB3.0
Max power       : 126mA

Partition type  : NTFS           Device active   : no
Aligned state   : 0 KB, Have been Aligned

Controller      : SMI
Controller model: SM3267AE S
Flash Vendor    : Micron 
Score           : 34      (Normal Score >= 30)
Firmware        : ISP 160323-2AE

 

I tried to use FDisk included in Hiren's Boot CD

But the USB stick is not recognized.

 

Any suggestion will be more than welcome...

 

Thanks for your answers.

Edited by bertrand
Link to comment
Share on other sites

Hello Toasted,

Thanks for your answer and as this USB drive is still under warranty I'll do what you suggest.

Even if I would like to try all possibilites to fix it like flashing the firmware but, as I said before, I don't know where I can find it and flash it neither.

Link to comment
Share on other sites

Bonjour,

Je n'arrive pas à trouver le logiciel qui permet d'installer le micrologiciel de ma clé USB Corsair Voyager GT 3.0 64gb (VID = 1B1C PID = 1A01).

Elle a présenté une succession de problèmes et finalement, le controller de la clé semble effacé.

J'ai essayé Innostor 902E MP Package V208_01_B5 qui était proposé sur http://flashboot.ru/iflash/

Mais la clé USB n'est pas détectée par ce logiciel. Alors que je suis parvenu à la détecter sur Windows.

Auriez-vous la technique pour mettre le micrologiciel à jour sur cette clé USB Corsair, s'il vous plait.

Merci d'avance de votre aide.

Bien cordialement.

 

Hello,

I can not find the software to install my Corsair Voyager GT 3.0 64gb USB flash drive (VID = 1B1C PID = 1A01).

It presented a succession of problems and finally, the controller of the key seems erased.

I tried Innostor 902E MP Package V208_01_B5 which was offered on http://flashboot.ru/iflash/

But the USB key is not detected by this software. So I managed to detect it on Windows.

Would you have the technique to update the firmware on this Corsair USB stick, please.

Thank you in advance for your assistance.

Best regards.

Link to comment
Share on other sites

  • 2 weeks later...
 Share

×
×
  • Create New...