Jump to content
Corsair Community

K95 RGB doesn't forward G keypresses to OS anymore


ygolohcisp
 Share

Recommended Posts

Hi everyone,

 

a week ago, my G keys were still working fine.

But now when I press them, nothing happens!

Nothing changed since then, except time passing.

 

I had mapped the G keys using "Remap Key/Button" to other keys.

And they were working just like those keys before, but now I don't get any input when pressing the G keys.

 

So I mapped a G key to a lighting macro to see if that would be triggered, and it DOES get triggered.

So that means the input event arrives at the CUE software but it doesn't forward it to the OS.

 

What could be the reason?

Any help will be greatly appreciated :)

 

(All non-G keys still work btw.)

Link to comment
Share on other sites

  • Corsair Employees
Try launching the uninstall tool for CUE through the Control Panel, then select the Repair option. If this doesn't correct the issue, make sure there is a "Corsair Composite Virtual Input" device in your Device Manager for Windows under the Universal Serial Bus tree.
Link to comment
Share on other sites

Thanks for the quick reply!

 

When I click the repair option:

yS3BblY6Rh6oVGgAx1V2IA.png

When I click cancel:

1-dJE9WwSv6QqJbWBPggBQ.png

USB Devices:

yTwt2837QSaYC4toAcmYcw.png

 

 

There is no "Corsair Composite Virtual Input" and I never had this but the CUE Software (v1.16.42) receives my G keypresses,

which I verified by mapping a G key to a lighting animation.

It just doesn't forward the translated keys to the OS anymore, e.g. when I map G16 to 'a' it used to work, but now it doesn't.

 

Is "Corsair Composite Virtual Input" only created by CUE v2? I haven't updated to CUE v2 because I was happy with the current version and nobody said if I can import my profiles created with v1 in CUE v2. Can I import them?

 

And: Can I get the G keys working by reinstalling the current CUE version?

 

Or could this be caused by the fact that my computer has been running for 2.5 months?

Edited by ygolohcisp
Link to comment
Share on other sites

Thanks.

It works now after I rebooted my computer.

It seems that just because my computer had been running for 2.5 months the CUE software stopped forwarding the G key events. (Even after restarting the CUE software.)

Why?

Is this bug fixed in CUE v2?

And is this issue fixed in CUE v2? (Higher CPU usage the longer the CUE software runs) http://forum.corsair.com/v3/showthread.php?t=169855

 

@Nick: Can I import my profiles from CUE v1 in CUE v2?

And can both CUE versions be installed at the same time or will they conflict?

Link to comment
Share on other sites

If you run a computer 24/7 it will eventually develope a problem or problems that need a reboot and it won't always be the same software causing it.

 

Eventually may be a long time away, though.

 

Hot patching is a dark art that allows people to safely and effectively patch running device drivers and the OS without needing a reboot. Microsoft supports this process, and there is a published walkthough showing how hotpatching has been used.

 

It has been reported that Hotpatching was first shipped by Microsoft with Windows Server 2003, but was removed in Windows 8 and later versions, because it was rarely used. During the 12 years support life of Windows Server 2003, only 10 patches used this technique.

 

If you are running Windows, plan to reboot once a month to install OS and other patches. https://msdn.microsoft.com/en-us/library/windows/hardware/dn653568%28v=vs.85%29.aspx?f=255&MSPPError=-2147217396

Edited by Comet ☄
Link to comment
Share on other sites

But it's weird that the only software causing problems after my PC is running for months is only the CUE software.

And the fact that it consumes more and more RAM and CPU the longer it runs, such that I have to restart it every 3 days.

No other software causes issues after running for months.

I'm not talking about trying to apply driver or OS updates while running the OS, just RUNNING existing software. That should NOT cause any problems!

It's not difficult to write reliable software without memory leaks that runs for months/years without problems, it's just a matter of QA and hiring people that know what they're doing.

 

Corsair advertises as "made in Germany" but the software seems to be more like "made in China" :(

 

And the support is bad, I never get replies to my tickets, so that I have to use this forum, and STILL no one has answered my question whether I can import my CUE v1 profiles in CUE v2!

@Nick (or another support person): pls answer my question :)

Link to comment
Share on other sites

 Share

×
×
  • Create New...