Jump to content
Corsair Community

H100i V2 not detected in link.


Gkmattos
 Share

Recommended Posts

Hi Everyone,

 

I'm currently having an issue on detecting my corsair H100i V2 into link. I've seen some threads and they suggest that you have the USB Link cable plugged into to a USB 3.0 motherboard slot and i've done it but so far no detection on Link software.

0I have a Z-170K ASUS motherboard, and I've connected the power PUMP power cable into the CPU_FAN and the fan connectors to the ones coming out from the pump.

 

Also the Corsair Link USB cable into a 3.0 USB motherboard slot.

Do you have any suggestions from this point on?

 

Thank you very much for all your help and assistance.

 

Best Regards,

Gkmattos

Link to comment
Share on other sites

I had exactly the same problem and the problem seems to have started about 2-3 weeks ago. I managed to get he H100i V2 appearing in Link 4 again today. If you open device manager, take a look under the "Universal Serial Bus Controllers" section. I saw that the "CorsairUSBXp Driver" showed a warning. Clicking on the properties of this driver I saw an error message stating "Windows cannot verify the digital signature for this file".

 

I followed the instructions in this post and Disabled Driver Signature Enforcement in Windows. Upon rebooting my machine, i then reinstalled Corsair Link 4 and the problem was resolved.

 

Hope this helps.

Link to comment
Share on other sites

I had exactly the same problem and the problem seems to have started about 2-3 weeks ago. I managed to get he H100i V2 appearing in Link 4 again today. If you open device manager, take a look under the "Universal Serial Bus Controllers" section. I saw that the "CorsairUSBXp Driver" showed a warning. Clicking on the properties of this driver I saw an error message stating "Windows cannot verify the digital signature for this file".

 

I followed the instructions in this post and Disabled Driver Signature Enforcement in Windows. Upon rebooting my machine, i then reinstalled Corsair Link 4 and the problem was resolved.

 

Hope this helps.

 

This is a known problem that there have been many posts about. If you are comfortable with disabling Driver Signature Enforcement, then go for it. A better solution would be for Corsair to FIX the problem.:veryangry

Link to comment
Share on other sites

This solution was not a permanent fix so decided to contact Corsair tech support. Here is their response. So far so good.

 

Please follow these steps:

- Uninstall the Corsair Link software and the Corsair Link Dongle REVOUninstaller or IOBit Uninstaller

-Go to file explorer, in the "Organize" pull down menu, open "Folder and search options", go to the "View" tab, and enable "Show hidden files, folder and drives

- Delete the following directory: C:\Users\"System name"\AppData\Roaming\Corsair

- *OPTIONAL run a registry cleaning software such as CCleaner

- Restart your system

- Install the Corsair Link software linked below

 

http://downloads.corsair.com/download?item=Files/Corsair-Link/Corsair-LINK-Installer-v4.7.0.77.zip

Link to comment
Share on other sites

Link sees my H100i v2 but it says the fans are at 0% rpm. It shows the pump running at 1650 rpm. Everything is plugged in correctly. And Link sees the H100i v2. But why does it show 0% rpm on fans and how can I fix that?

 

Make sure they are actually turning (or not). Confirm the fans are plugged into the pump block and not anywhere else.

 

Also, your pump speed is too low. Even at the quiet pump setting, you should be around 1900-2000 rpm on the H100i GTX/v2. Make sure your motherboard header powering the cooler is set to 100%, disabled, or however GA describes a constant 12v signal in their BIOS. Since both the fans and pump draw power along that line, too low a voltage could prevent either from starting.

Link to comment
Share on other sites

I went back into my BIOS and checked the CPU Fan settings. I can set it to Voltage like what's suggested here. But under speeds I don't have any settings for 100% or 0% or anything like that. I tried different settings and finally settled on Disabled. Now CL4 is showing 1860 rpm for my fans. 2790 for Pump. Also 20.8 for CPU temp and 35.8 for water temp. Does that sound good to you? I am new to water cooling and think I finally have things set up. How do those speeds/temps look? Thank you for responding.
Link to comment
Share on other sites

Yes, that is more like it. Disabled is fine and generally sets the fan controller to maximum while "disabling" any fan curves or changes. That's what you want. 12v from the header. Make all changes in Link to control fan or pump speed.

 

I think you are going to see some kooky CPU temps on AMD with the customary quirky readings, but you'll need someone with more experience with them to offer advice. The real CPU temp at idle is likely near the coolant temp. Also take note the fans curves in Link (quiet, balanced, performance) are based on coolant temp with max speeds around 40C=100% fan. There is nothing special about that number and it is not a threshold. If it's Summertime, your entire case is going to be 35C ten minutes after you power on and the fans will be running near max all the time. No need for this. Make a custom curve to match your acceptable fan noise levels. Moderate speed on a 240mm radiator should be enough for almost anything except extended stress testing. Your coolant delta from initial to load is going to be relatively small and while you can make decent gains going from low speed to medium, the gains at the higher end are thin. Set your highest tolerable fan speed to 2-3C above your normal coolant temp peak then slope the remainder up to 100%. You will get an auditory warning if things are out of range.

Link to comment
Share on other sites

Ok. Thanks for the info. I got a good deal on the H100i v2 from Newegg as it was a refurb. So there wasn't any install instructions at all. So everything I have learned is from this forum. I appreciate the info. I did make a custom setting and will "play" a bit with it and find exactly what I want. So far I am pleased with what I am seeing.
Link to comment
Share on other sites

  • 1 year later...
This solution was not a permanent fix so decided to contact Corsair tech support. Here is their response. So far so good.

 

Please follow these steps:

- Uninstall the Corsair Link software and the Corsair Link Dongle REVOUninstaller or IOBit Uninstaller

-Go to file explorer, in the "Organize" pull down menu, open "Folder and search options", go to the "View" tab, and enable "Show hidden files, folder and drives

- Delete the following directory: C:\Users\"System name"\AppData\Roaming\Corsair

- *OPTIONAL run a registry cleaning software such as CCleaner

- Restart your system

- Install the Corsair Link software linked below

 

http://downloads.corsair.com/download?item=Files/Corsair-Link/Corsair-LINK-Installer-v4.7.0.77.zip

 

I'm having the same issue with my H80i V2 and I tried these steps and it didn't work. Still looking around for a solution that works for me.

Link to comment
Share on other sites

 Share

×
×
  • Create New...