Jump to content
Corsair Community

Commander Pro not detected by corsair link


Gofran
 Share

Recommended Posts

hello

can anybody please help me mine commander is not detected by commander pro mine pc detects the device but it cannot being detected by corsair link i had shutdown pc and unplug it still same issue

 

re inserted the usb header same issue reinstalled corsairlink same issue

what can i do

 

Motherboard formula ix z270

Processor i7 7700k

Memory trident rgb cl14 32gb

Video Card # 1 strix 1080TI

Hard Drive # 1 m.2 950

Hard Drive # 2 m.2 950

Hard Drive # 3 seagate 2tb

Hard Drive # 4 ssd samsung

Optical Drive # 1 spatha

Optical Drive # 2 isku fx

Power Supply corsair rm750

Case phanteks evolve atx

Operating System 64bit

Link to comment
Share on other sites

  • Corsair Employees
hello

can anybody please help me mine commander is not detected by commander pro mine pc detects the device but it cannot being detected by corsair link i had shutdown pc and unplug it still same issue

 

re inserted the usb header same issue reinstalled corsairlink same issue

what can i do

 

Motherboard formula ix z270

Processor i7 7700k

Memory trident rgb cl14 32gb

Video Card # 1 strix 1080TI

Hard Drive # 1 m.2 950

Hard Drive # 2 m.2 950

Hard Drive # 3 seagate 2tb

Hard Drive # 4 ssd samsung

Optical Drive # 1 spatha

Optical Drive # 2 isku fx

Power Supply corsair rm750

Case phanteks evolve atx

Operating System 64bit

 

Have you tried completely uninstalling Corsair LINK and reinstalling as admin? If Windows is detecting it and Corsair LINK isn't, you could try using a different USB 2.0 header on your motherboard.

Link to comment
Share on other sites

 Share

×
×
  • Create New...