Jump to content
Corsair Community

weird issue with the k70 rgb


cg1245
 Share

Recommended Posts

hello, I have a k70 rgb keyboard and it has been working just fine without any issues since I got it a year ago. yesterday, I was playing a game and my keyboard just randomly stopped working. the rgb thing stopped too and all the keys were red, but this time some keys were glitched out and they were blue. I've tried updating drivers and using a different bios setting on the switch and nothing fixes it. I think it might be because I have an amd ryzen cpu and I am using windows 7 with it. does anyone know how I can fix this? thanks
Link to comment
Share on other sites

I had some weird issues with my keyboard yesterday also. Try some of the following things i've mentioned below. As Toasted mentioned above a soft reset fixed my problem.

 

- Try CUE versions 2.16.87 and 1.16.42 (rolled back)

- Try Firmware 2.05 and then rolledback to firmware 1.29

- Keyboard works okay with the BIOS switch on the keyboard selected?

- Setting profile back to default

- Test on a different computer and if the problem exists

Link to comment
Share on other sites

I had some weird issues with my keyboard yesterday also. Try some of the following things i've mentioned below. As Toasted mentioned above a soft reset fixed my problem.

 

- Try CUE versions 2.16.87 and 1.16.42 (rolled back)

- Try Firmware 2.05 and then rolledback to firmware 1.29

- Keyboard works okay with the BIOS switch on the keyboard selected?

- Setting profile back to default

- Test on a different computer and if the problem exists

 

I have tried all of these and the keyboard works just fine in bios switch 3, its labeled 4, and the problem still happens on my laptop.

Link to comment
Share on other sites

 Share

×
×
  • Create New...