Jump to content
Corsair Community

Keyboard acting wild


Darkstar82
 Share

Recommended Posts

So my computer was idle and suddenly the keyboard went nuts. Pressing random keys etc.

Seemed like the top row of keys (ESC and all F keys) were being pressed. I couldn't open anything, do anything.

 

 

Things I've tried:

 

Used the cue software to force a firmware install, no change

Used the hold esc when you plug in, nothing happens.

Tried holding the reset hole as I plugged in the device. Removable drive pops up with firmware.bin (2.05). Tried an older firmware (1.3) I found on this site, software reports malfunction and keyboard doesn't work at all. Put old firmware back.

 

Every time I plug it in, it all goes red with white WASD/Arrow keys. About 20 secs later I get the rainbow pattern. Keys work but the F keys are being pressed by forces unknown.

 

Stunned. Never have I had a keyboard of all things just freak out. Are we making them too smart? Mechanical failure is one thing..

 

Any ideas? Typing all this out on my very old laptop isn't fun at all.

 

To make things worse, I bought this off ebay about 5 month ago. So no chance of an RMA or anything like that, gutted.

I have no other keyboards anywhere, I'm screwed.

 

Updade: Manged to force it into BIOS mode, who knew. The scroll lock flashes and the keys are red with white WASD but every key seems to work (including the F keys). Typing this from it now. Wtf? Gotta stay in BIOS mode forever?

Edited by Darkstar82
Link to comment
Share on other sites

Mine acting similarly, it happens with several keyboards not just my strafe. I suspect M$ has released some broken update that's having a bad reaction with some chipsets in some motherboards. I'm typing on the same strafe that goes nuts on my desktop machine. it works fine on both laptops I have. I do not have a polling switch or if I do I don't see where it may be. I do not see any sort of reset hole on the keyboard if there is one. I found a chipset update for my gigabyte 990fxa-ud5 chipset but doesn't seem to have been a change, clean install of windows 10 still happens. I had sent back a razer keyboard acting weird I assumed I'd done something to it but other keyboards acting weird too typing wrong characters wild auto spacing doing all sorts of weird stuff I have an old roccat, an old logitech that truly is probably just dead now the strafe and a teensy usb keyboard that I was using on my game console. This is driving me nuts I want my strafe back on my main machine, I've exchanged it once but I'm now convinced this is windows related or conflicts with the chipset in my motherboard and not a bad keyboard. The strange part is that my whole problem started when I installed my gaming router and netgear apparently installed some sort of idiot proofing during the setup...those things should be gone now after a clean install with all partitions removed etc. gigabyte 990fxa-ud5 with 9370 cpu, 16 gig ram, nvidia 1060 video card, external blue ray drive. It happens on or off a hub. Please fix this guys, it seems sort of intermitting but i can tell you it's happening all the time with mine and I'll happily let you monitor my machine when I plug in the strafe, whatever you need!!!
Link to comment
Share on other sites

 Share

×
×
  • Create New...