Jump to content
Corsair Community

Corsair Link Crashes After Sleep Mode - 4.8.0.82


Rick W
 Share

Recommended Posts

Hi All,

 

My Specs:

MoBo – MSI 970 Gaming Carbon

CPU- AMD FX9590

Cooler- Corsair H80i V2

OS – Win7 64bit

Corsair Link Ver- 4.8.0.82

 

My Corsair Link fails to wake up after sleep mode. The H80i Water Temp is not reading (frozen number) and does not control the CPU fans which can be dangerous IMO. (Note the rest of the temps and fan speeds all read fine.. it’s just the Water Cooler that is not reading). Obviously a USB driver:

 

SO, I have traced the suspect back to the Corsair USBXp Driver version 3.3.0.0 (7/14/2010)! (7 year old driver..)

 

After waking from sleep and the Corsair Water Cooler readout/control is frozen I go into device manager and Disable/Enable that driver and the Corsair Link comes back online reading the Water Temp and controlling the fans.

 

I've seen others reporting this issue but there never seems to have been a fix from Corsair. Any fixes for this?

Link to comment
Share on other sites

  1. My Specs:
  2. Corsair Link Ver- 4.8.0.82
  3. I've seen others reporting this issue
  4. but there never seems to have been a fix from Corsair.
  5. Any fixes for this?

Welcome to the forum and I too suspect it's an issue with the SIUSBXP driver.

  1. I advise you to use http://forum.corsair.com/forums/profile.php?do=extra
  2. You should recheck with the latest CL 4.8.2.1 release even though I expect it will still have the issue.
  3. You should have linked to a post about this such as http://forum.corsair.com/forums/showthread.php?p=918483 or better still posted to the same thread.
  4. It's quite common for Corsair to fail to address issues, see http://forum.corsair.com/forums/showthread.php?p=903472.
  5. AFAIK the only "fix" when using CL4 is to disable sleep :(: I also expect "fast boot" needs to be disabled ;):.

Link to comment
Share on other sites

Welcome to the forum and I too suspect it's an issue with the SIUSBXP driver.

  1. I advise you to use http://forum.corsair.com/forums/profile.php?do=extra
  2. You should recheck with the latest CL 4.8.2.1 release even though I expect it will still have the issue.
  3. You should have linked to a post about this such as http://forum.corsair.com/forums/showthread.php?p=918483 or better still posted to the same thread.
  4. It's quite common for Corsair to fail to address issues, see http://forum.corsair.com/forums/showthread.php?p=903472.
  5. AFAIK the only "fix" when using CL4 is to disable sleep :(: I also expect "fast boot" needs to be disabled ;):.

 

Hi Ray,

1. Thank you I will do so.

2. Yeah, just installed CL 4.8.2.1. Same 10 year old driver. It’s def that driver.

3. Had a look through that thread, it doesn't look promising eh. (The more threads the more embarrassment for Corsair on this).

4. My gawd.. I doubt I will buy anything from Corsair in the future. s***ty experience so far.

5. Ya. I’ve even set all my USB hubs to stay awake and that didn’t help. Fast boot is off as well.

6. Why the heck aren’t YOU on the dev team at Corsair lol :-)

 

If you can write a simple workaround to disable/enable the driver then they can too. This is laziness pure and simple. NO updates on this driver in ten years is pathetic.

 

NOTE: I have opened a support ticket on this matter and will report back on what they have to say..

Edited by Rick W
Link to comment
Share on other sites

 Share

×
×
  • Create New...