Jump to content
Corsair Community

Corsair Gaming VOID USB RGB Gaming Headset Malfunction


Justin Prince
 Share

Recommended Posts

Hello,

 

So I've recently purchased the Corsair Gaming VOID USB RGB Gaming Headset - Carbon from Amazon and have been using it for a few days now.

 

Today out of nowhere, while things were working properly I suddenly see my headphones get disconnected. I unplug and replug them in and they are not recognized. I go ahead and look up as usual what I can do, I also tried to restart my computer and unplug the power supply.

 

Whenever I try to connect the headphones to the USB port it states "The last USB device you connected to this computer malfunctioned, and Windows does not recognize it.

 

Everything was working just fine and now all of a sudden it's malfunctioning, any suggestions as of how to solve it would be appreciated.

Link to comment
Share on other sites

Yes, I've tried it on my other computer and it just seems like it does not detect it either. Though after I did that test, I came back to my PC, plugged it in in some weird way (forced) and it got detected. I used it again for about 20 more minutes and then it died again, tried to re-plug it in and nothing.
Link to comment
Share on other sites

 Share

×
×
  • Create New...