Jump to content
Corsair Community

Scimitar Pro G keys stop working


axeman
 Share

Recommended Posts

Bought a K70 and Scimitar Pro the other day.

 

I got my G keys on the Scimitar Pro working the first day. Simple stuff: G1 = keypress 1.

 

Next day? Didn't work. CUE software running. Restart. No Joy.

 

Redid the G-key actions to be Key remaps instead of Macros. Worked. Until I turned off computer. Turn it back on? No joy.

 

I have Actions set, and Action library set. I changed the Default profile, and created a duplicate profile. Today? Can't get the buttons to work.

 

Note that when I turn my computer on, my keyboard displays the custom colors I set, before any software is loaded. My mouse remains dark until computer on, and when I open CUE software, it switches to my colors, but G buttons don't work. Actions are set correctly.

 

I'm using Firmware v. 1.10, and have forced an update even though it's the latest version.

 

I've tried plugging mouse into USB on K70 (worked the first day), tried plugging it in straight to computer.

 

I JUST WANT MY MACRO BUTTONS TO WORK! I'm fine running CUE software since I can't seem to find a way to download setting to mouse itself.

 

HELP! All internet searches show old software, which isn't the same.

Link to comment
Share on other sites

Sounds like a driver related issue.

 

If you are using Windows 7, Make sure the hotfix in this thread is installed.

http://forum.corsair.com/v3/showthread.php?t=166144

 

If you are not running Windows 7, What version of CUE are you running?

When the macros stop working, Open Device Manager and expand System Devices and Human Interface Devices. Do you see Corsair Bus under System Devices and "Corsair composite...device" under HID?

 

Please fillout your system specs.

http://forum.corsair.com/v3/profile.php?do=extra

Link to comment
Share on other sites

 Share

×
×
  • Create New...