Jump to content
Corsair Community

Fans plugged into Commander Mini run at max speed when PC wakes from sleep


DeadxWreckoning
 Share

Recommended Posts

Hi guys,

 

So I have a minor issue and was curious if anyone else has experienced this issue and knows how to remedy it.

 

I'm using a Commander Mini with 5 fans plugged into it (2x AF140 on front of case, 2x AF140 on H115i radiator, and 1x AF120 on rear of case). Every time I wake my PC from sleep, all five fans are at max speed, regardless of the profile set before it was put to sleep, and will stay at this speed. Every time I wake my PC, I need to go into Link and re-select my low-speed fan profile, though it still shows it's selected for the fans to re-enter a low-speed state.

 

To add, this happened to me on Windows 7 too (now on 10) and on my old AMD build (now running Intel) so it seems like it's definitely a Commander Mini bug. Only thing I can think of is some sort of incompatibility between the 3-pin AF fans and the Commander? Maybe the service crashes on wake and doesn't restart until I select a profile?

 

Currently on Link 4.7.

 

Any help is appreciated.

 

Thanks.

Link to comment
Share on other sites

Nope, I have the same problem using the Commander Pro. My fan profiles do not work after waking from sleep and my H115i becomes unresponsive to any changes. Disabling and Enabling via device manager fixes the problem until the next sleep. It believe possible to create a script to automate this process, but I ended up just turning off sleep altogether. It is not worth the risk of overheating my hardware if I forget... :sigh!:
Link to comment
Share on other sites

I am unable to change the speed of the fans on the cooler.

 

If you exit CL4 then from Windows Device Manager you disable and then enable the H115i, restart CL4 can you then change the fan speeds?

Edited by red-ray
Link to comment
Share on other sites

Yes, that is the only reasonable workaround that I have found. I just ended up turning off sleep altogether to save me the trouble.

 

I suspected it would and I think the root cause is the SIUSBXP driver does not handle Windows PNP power transitions correctly.

 

In my code I worked around the issue by automatically doing the disable/enable when the system resumes from sleep, see http://forum.corsair.com/forums/showthread.php?p=857462

 

I am not sure what to suggest, you could try asking Corsair to fix their driver.

Link to comment
Share on other sites

  • 2 years later...
This is something I forwarded to our Validations team to look into. If it's driver-related, we may or may not be able to fix it depending on whose driver it is. But we can at least look into it.

 

This is an old thread but did this lead to anything? I just built a new computer and have this problem.

 

My old computer had same commander mini and it had no problems, but I'm not sure if I used hibernate instead of stand by.

 

H100i works fine, but corsair case fans do not.

 

Also another problem is CL4 does not show processor data on this new computer. Only "Intel processor" and Load %.

 

No temperature, or even type

Link to comment
Share on other sites

Also another problem is CL4 does not show processor data on this new computer. Only "Intel processor" and Load %.

 

No temperature, or even type

 

Probably not since the Link program ended more than 2 years ago and you are using a Z490 board and Comet Lake CPU.

Edited by c-attack
Link to comment
Share on other sites

Probably not since the Link program ended more than 2 years ago and you are using a Z490 board and Comet Lake CPU.

 

Would use iCue but it doesn't support Commander Mini. So I'm screwed. Guess I need to upgrade the commander then.

Link to comment
Share on other sites

 Share

×
×
  • Create New...