Jump to content
Corsair Community

Corsair Vengeance RGB 3600 LEDs dieing.


Karlgamer
 Share

Recommended Posts

I bought a set of four Corsair Vengeance RGB 3600(CMR32GX4M4C3600C18).

 

They all lit up when, but then one went dark and recently another went dark.

 

One of my remaining two cycles through the rainbow like crazy.

 

If this is something I can fix I'll do whatever it takes to fix it, otherwise I guess I'll just use my warranty.

 

Although, I don't want this to happen to the next set I receve.

Link to comment
Share on other sites

Aura Seems to control both of the sticks that are still lit, however one of them seems to be going at a different speed then the rest of the system(aka a lot faster).

 

Two sticks aren't lit at all. Although they were when I initially installed them.

Link to comment
Share on other sites

Weird, I put 128GB(8 sticks Dominator Platinum) in my computer yesterday, Asus Prime X299 Deluxe and PSU AX1200i without any problem, all memory sticks light up and functions as they are suppose to with Aura. Maybe a motherboard BIOS(firmware)update will fix it. Hope you get it solved. Edited by TrinityPCW
Link to comment
Share on other sites

  • Corsair Employees
Weird, I put 128GB(8 sticks Dominator Platinum) in my computer yesterday, Asus Prime X299 Deluxe and PSU AX1200i without any problem, all memory sticks light up and functions as they are suppose to with Aura. Maybe a motherboard BIOS(firmware)update will fix it. Hope you get it solved.

 

Dominator Platinum doesn't offer software control of the DRAMs onboard LEDs, so as long as the Dominator Platinum modules are getting power, the LEDs will be lit. For Vengeance RGB it can be a software issue/conflict causing this or an actual hardware issue. At this point, I suggest that OP contacts our customer support team for a resolution.

Link to comment
Share on other sites

  • 1 month later...

So, I got my memory back from Support. Which took a very long time. The memory showed up suddenly without warning. Had to pick it up at the office. Looks like a brand new kit. I wasn't told what went wrong with my first kit, and I'm a little concerned that whatever happened to my last kit will happen to this kit if I put it in my computer.

 

If it was just a faulty kit then everything should be fine with my new kit, but if my motherboard or software was too blame I would like to know how to fit it.

 

I believe I have my latest bios and Aura software.

Link to comment
Share on other sites

 Share

×
×
  • Create New...