Jump to content
Corsair Community

AX1200i - Dead? Clicking sound when start button is pressed


Klad
 Share

Recommended Posts

Hello!

 

I seem to have a issue with my AX1200i perhaps, the computer has worked flawless since it was new, 6 months ago give or take..

 

Last night, the PC died like it lost all power and i cannot turn it on again, the PSU makes a clicking sound and nothing else happen.

 

I have removed the PSU, disconnected all cables and pressed Self-test button, that seems to work, it turns on and is green light. I have taken the 24-pin cable and bridged the cable with a paperclip, that turns on the PSU as well.

 

Tried connecting the PSU back to the computer and still, nothing happens - PSU clicking. Seems to be a lot of people having issues with ax860/ax1200 clicking from what i can gather when google the issue

 

But can anything else be broke in my PC? Motherboard? I wish i had another PSU to test the PC with but sadly i dont and its Sunday, everything is closed where i live :(

 

Asus z270i Strix

Intel 7700k with Corsair H100i V2

Corsair 32GB 3000Mhz DDR4

MSI 1080Ti Sea Hawk X

M.2 EVO 500GB Flashdrive

Link to comment
Share on other sites

 Share

×
×
  • Create New...