Jump to content
Corsair Community

Flash Older Firmware H100i


GGCL

Recommended Posts

Greetings everyone.

 

My experience with the H100i has been quite disapointing since the day I bought it. With just 2 months of usage the green led stopped working completey, and since I have a black&white build, I opted for turning the leds off completely. For a couple of months now I have an issue where even after setting all RGB parameters to 0, the led still has a slight purple light (R+B) and I can't turn it off, it's bothering me a lot, so before I throw this cooler in the trash can, is it possible to flash older firmware or to reflash the same firmware again? Corsair Link 4.8.0.82 doesn't seem to have any option whatsoever. Anything else I should try?

 

Thanks in advance.

IMG_20170731_132538437.thumb.jpg.a9d93371f6e454ba5dfc865c601135f9.jpg

Link to comment
Share on other sites

It's possible, but you need to use CL 3.2.5742 as CL4 can do this.

 

I suspect if you set 1,1,1 rather than 0,0,0 this will be 99% of what you would like.

 

Unfortunately 1,1,1 and 0,0,0 and 0,255,0 or even 1,255,1 are having the exact same purple color and same brightness. Where can I find older H100i firmwares to download? I recall using the 1.0.7 when my unit was still working fine, now I'm at 1.1.3.

 

Thanks for the help.

Link to comment
Share on other sites

I have no idea, but have a Plan B

 

Thank for your help! I've installed the CL version 3.2.5742 you said, but I can't find any firmware update/flash option on it. How should I procceed?

 

/EDIT

 

I think i've found it.. went to search updates and clicked on Manual Update, checked the H100i checkbox and on the firmware dropdown I've selected custom and then the 1.0.7.s19.gz, but it gives me an error. Image attatched.

Capture.PNG.6c7186d091365d232916e8b361e05e4f.PNG

Link to comment
Share on other sites

How should I procceed?

 

You could try asking Corsair support via https://support.corsair.com/

 

As I recall CL 3.2.5642 can only update firmware so I would:

 

  1. Copy CLink_H100i_v1.0.7.s19.gz to CLink_H100i_v1.2.7.s19.gz
  2. I think there is a check for updates somewhere, try and find it
  3. Update from 1.1.3 to 1.2.7 which is actually 1.0.7 :bigeyes:
  4. Does this make sense and please let me know if it works.

Link to comment
Share on other sites

You could try asking Corsair support via https://support.corsair.com/

 

As I recall CL 3.2.5642 can only update firmware so I would:

 

  1. Copy CLink_H100i_v1.0.7.s19.gz to CLink_H100i_v1.2.7.s19.gz
  2. I think there is a check for updates somewhere, try and find it
  3. Update from 1.1.3 to 1.2.7 which is actually 1.0.7 :bigeyes:
  4. Does this make sense and please let me know if it works.

 

Is there any chance I would brick my H100i doing this procedure?

Link to comment
Share on other sites

Yes, It happened to me a long time ago and I needed to RMA, see http://forum.corsair.com/forums/showthread.php?t=134052

 

Search the Cooling and Corsair Link forums for bricked and you should find other examples.

 

Maybe you should check with Corsair support if you can RMA first.

 

I tried to RMA it about 2 years ago when the green led vanished, but it turned out to be extremely expensive to send it over to the US, about half the price of a new H100i back then, and it would take a month or two to send ir over and get it back, so I cancelled my RMA ticket. Unfortunately, I've had too many problems with Corsair since I've started my rig, needed the RMA three times already for different products, first brand ever to give me so much headache. Guess I shouldn't buy Corsair anymore..

 

I tried to rename the ...1.0.7... file to ...1.1.7... (which is bigger than 1.1.3), but still got the same error reported above. Guess I'have to stick an adhesive to block the light, crack it open to cut the led wire or something, or just live on with a Black&White and now Purple build, which looks awful.

 

Thank you for your patience and for the help, really appreciate it.

Link to comment
Share on other sites

I bricked 3 H100i coolers by updating the Firmware (I can be a bit slow sometimes) the first one, I didn't realise that Link had tried to update it, the second one I had my suspicions about but after the third one I was certain, so I sent all 3 back and bought an H110i GT instead. Excellent cooler.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...