Jump to content
Corsair Community

Strafe not getting recognized


Torugasan
 Share

Recommended Posts

I got my Corsair Strafe mechanical keyboard today but since the first time I've plugged it in, the only working things are the lights. It does not get recognized neither by my computer nor the software.

Things I've tried;

1. The little small reset button

2. Trying to re-install all my keyboard devices from device manager.

3. Plugging off and in while holding down ESC

(I'm sure that the USB 2.0 ports are working.)

Link to comment
Share on other sites

Try a different computer and see whether that changes anything.

 

Try putting the keyboard into BIOS mode and see whether any thing changes,

F1 followed by the Windows lock key. The scroll lock indicator will flash to indicate BIOS mode, to exit, use the same key combination.

 

If that does not work, Contact your retailer and see whether they can replace it for you or put in a support ticket with Corsair and see whether a hard reset resolves the issue.

Link to comment
Share on other sites

Just realized the cable was damaged inside lol.

Probably the cable got damaged because of the transport and cargo.

Thank you very much.

(Btw. As it worked for one person already, holding down the ESC button and plugging in the usb with keyboard sign on it usually fixes the problem. )

Link to comment
Share on other sites

  • 1 year later...
I have read this thread and tried everything mentioned. My problem is this; If I plug the Strafe RGB in while the computer is on and at the desktop, the computer does fine in recognizing the new keyboard. The problem is if I reboot or shut the computer off and start it up again the computer will not go past the POST. I don't know what else to try or do. I have never had a problem like this. If anyone has any thoughts or a resolution to this problem I would appreciate it, thank you
Link to comment
Share on other sites

  • 2 weeks later...
 Share

×
×
  • Create New...