Jump to content
Corsair Community

CX430 can't handle the 3.3v line under low load


Recommended Posts

I'm struggling with four new computers that I built for over a week now. I finally discover the problem some days ago and it is the Corsair CX430 PSU. Yep, four of them. In fact, I believe, all units of this Corsair PSU has this problem (and probably other models too). Unfortunately, the Corsair support was not what I expected (I was expecting some quality service). They told me "Feel free to go on our forums." (they exact words), so....


My computers have this specifications:


  • Intel i3 7100
  • Gigabyte GA-B250M-D3H
  • G.Skill Ripjaws DDR4 2400mhz 8Gb
  • Intel 600p 128 SSD (also tested with Samsung 960 evo)
  • Corsair CX430


I knew that this pc power consumption will be very low, so, I bought the weakest PSU (with 80 Plus) I found. The power consumption is indeed very low, in IDLE the entire system consumes 5~10Watts, in load it consumes 50Watts tops.


This is the PC running in idle. The UPS is showing the total power consumption of the system. Usually shows a consumption in the range of 5~12 Watts, but eventually displays 0 ~ 2 watts like this:



After assembly them I started to have all kind of weird problems. Windows crashes, BSOD, sometimes I couldn't even install the OS because of strange errors coming from nowhere. I changed all the motherboards (I was using Asus H270M Plus at the beggining) and the problem persisted.


In the end, the problem was the PSU. I tested with a generic $5 PSU and it worked perfectly. I tested the PSU and noticed that when the power usage is too low on the 12v line, the 3.3v line can't handle the NVMe SSD. The NVMe SSD just shuts down when this happens: [ame]



If I connect some dummy power on the 12v line (like a 20w lamp) it works perfectly. Now, take a look what happen when I switch off the lamp: [ame]



With any significant load on the 12v line the PSU works fine, but it can't handle the 3.3v on idle. The "Power load" (dummy load) option on the motherboard bios is not enough to solve this case.


So, in order to make this PSU to work in my 5~10 Watts PC, a friend of my created a external voltage regulator, attached to a SATA connector. With this, the 3.3v line stays stable.




If you're building a low-power PC, do not buy this power supply.

Link to comment
Share on other sites

  • 4 weeks later...

Thank you!


I have been trying to get an NVMe drive working for weeks and finally succeeded after reading your thread. I tried swapping motherboards (ASRock H270M-ITX, Gigabyte H270N-Wifi), NVMe drives, CPUs (G4400 and G4560), and power supplies (CX430 and CX430M) all to no avail.


I saw your post last night and this morning tried a third power supply and now everything works!


As NVMe devices become more widespread I bet more and more people will come across this problem.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...