Jump to content
Corsair Community

Corsair RGB Void Headset(White) Dead after FW failure


Recommended Posts

Just got the headset in the last 24 hours and was updating everything on it with the CUE 2.12.66 and saw it have a firmware update available. Started the update and it got to 10% before freezing the program. After waiting 15 mins without it responding I had to close it.


Now the headset isn't responding, Windows doesn't recognize it as anything but a malfunctioning device, and it apparently can't enter this "bootloader mode" that was listed in a sticky. The CUE program won't see it as connected so I can't attempt to redo the firmware update.


I've submitted a ticket before I went to bed last night but I would very much like to have a working headset before tonight.



I've installed every windows update to see if I could get it to recognize it as the bootloader version of the headset to no avail.

I've tried pairing them and nothing.

Holding the reset button on the dongle doesn't help.

Holding the power/mute/any button on the headset while connecting the USB cable changes nothing.

I've tried everything listed in all 10 pages of http://forum.corsair.com/forums/showthread.php?t=152196 and haven't had any success.


Devices and Printers sees the dongle as Corsair VOID RGB Wireless Gaming Headset and the USB connected headset as Unkown Device Error Code 43.


It seems like the firmware failure wiped any and all functionality from the headset.

Link to comment
Share on other sites

  • 2 weeks later...


I sent it back and got a replacement, now this one is having a soft buzzing in the left speaker depending on how I tilt my head. Its workable but I see it failing in the not to distant future, which will be another week and a half wait for a 3rd attempt at a fully working headset. Exact same issue as this thread: http://forum.corsair.com/v3/showthread.php?t=167305


Also having problems with the CUE2 software. If the I restart my computer or turn the headset on/off it isn't recognized by the program. The sound still works but I can't check the battery left or change the lighting settings.


The first headset had none of these issues.

Link to comment
Share on other sites

I figured out it had to do with the start with windows option. The program was starting before the device was recognized, starting it manually is working great now. Minus the buzzing.
Link to comment
Share on other sites

  • 3 months later...


This topic is now archived and is closed to further replies.

  • Create New...