Jump to content
Corsair Community

Brand new mouse, CUE freezes when opened

Recommended Posts

Reset the mouse firmware and see if that helps.

Unplug the mouse, Hold both left and right buttons down while plugging the mouse back in.


if that does not help, try a different USB port as well and see if anything changes.

Link to comment
Share on other sites

Tried what you suggested with cue open, closed, and uninstalled. Still no progress past 0%. Also if i close the Cue software, when reopening it it loads for about 3 seconds then just doesnt open. kind of crappy that i cant use a $80+ mouse out of the box. Customer support only solution was to take it to the store 30 minutes away and get another one/make a ticket on corsairs website. All ive had is razor mouses to this point. Kind of sad that in 2017 software is ever a problem other than immediate fix's. looking for a solution this has been a problem since 2014 with software. WTF??? Sorry for rant, just really disappointed. There anywhere to find a file of the firmware for the scimitar pro that from what im told fixes the problem. dont want to wait 2 days for my ticket lol. thanks for the help.
Link to comment
Share on other sites

1 - Please completely exit out of the Corsair Utility Engine Software

2 - Disconnect the unit entirely from your system

3 - Using a paperclip, thumb tack, or thin needle, please hold down on the reset button (located next to the polling rate switch, under the left leg of keyboard, or under the top weight storage for mouse)

4 - As it is pressed down, please connect the unit to a USB 3.0 port on your system (please ensure the connector labeled with the keyboard icon is connected only)

5 - A file explorer pop-up (check file explorer if it doesn't) will be displayed showing drive name as CRP_DISABLED

6 - Please ensure you first delete the firmware.bin file that is on the CRP_DISABLED drive. Transfer the ISP bin file that is attached to this ticket over to the CRP_DISABLED drive.

7 - Insert the unit as you normally would to have the keyboard initialize.


I cant attatch file so either need to email or pm is that works. new to site so unsure. let me know

Link to comment
Share on other sites

  • 4 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...