Jump to content
Corsair Community

New Corsair memory doesn't work with my computer.


Recommended Posts


On the begining sorry for my english.

I have bought new RAM for my computer.

It's Corsair XMS3 DDR3 1600MHz, 8GB (2x4GB) 9-9-9-24, 1,65V ver 8.23 (CMX8GX3M2A1600C9)

I want to replace my old memory Corsair XMS3 1600MHz, 2GB (2x1GB) 7-7-7-20, 1,8V ver 4.1 (CM3X1024-1600C7DHX)

My mainboard is Gigabyte GA-EP45T-DS3R

Procesor: Intel Core2Duo E8500.


With my old memory computer worked fine but when I install new RAM it doesn't start. There is no even BIOS screen. It just restarting all over every 5 to 15 seconds.

I tried diferent sockets, inserting only single memory unit, i updated BIOS, I reseted BIOS by removing battery. I think I have tried everything. What's wrong?

It's impossible that both new RAM are broken.

Please help, what should I do?



Link to comment
Share on other sites

If there are only ICs on one side of the module, they were built from 4Gbit ICs and these are too high density for P45. Even some of my double sided 2x4GB kits built from some of the last 2GBit ICs that were made some years ago, did not work on P45/X38/X48 at all. I don't know if there is any Corsair kits left, that would still be compatible with your system, but i doubt it.


Statement from last year about a similar issue:

99.9% of our DDR3 memory are high density. The only memory kit that i know that is low density is the Apple certified sodimm at 1066mhz.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...