Jump to content
Corsair Community

Weird memtest errors in dual channel mode?!


rashinile

Recommended Posts

System:

 

Asus p4c800-e deluxe

p4 3.2mhz prescott w/ ht

Corsair XMS TWINX1024-3200C2PT running in dual channel

Sapphire x800 pro

Soundblaster Audigy 2 ZS

Hitachi 250GB SATA HD

Enermax Noisetaker 420w PS

 

BIOS version 1019 current

Legacy USB disabled

Performance Mode [auto]

Performance Acceleration Mode [auto]

 

Ok I need help... So I built this system from the ground up, set memory timings to 2-3-3-6 and upped dram voltage to 2.75 before I installed windows, posted fine so I went ahead and installed XP and all my software ect. I got a weird windows memory error while using Acdsee image viewer for the first time so I decided I better run memtest. Popped in the memtest+ diskette and low and behold about 60 errors in tests 6-8. I changed back to spd setting and ran memtest and got the exact same results.

 

Now here is where is gets strange. I've tried each stick individually in all 4 dram slots and no errors at all in either stick at 2-3-3-6. I also tried putting both sticks together in single channel mode and got no errors at all. It's only when I put the sticks in slots 1+3 or 2+4 and run them in dual channel that I get errors in memtest test 6-8. I wasn't hopeful because the spd settings wouldn't even run without errors but I thought I would relax some of the timings just for the heck of it. I realized that if change the RAS# precharge to 4t and leave everything else as is it gets rid of all the errors in test 6. I made several complete passes through memtest at 2-3-4-6 with no errors, but I decided I had better let it run all day while I was at work. When I came home I discovered that it still had errors. About ~5 errors in test 7 and ~5 errors in test 8 in about 50 passes of memtest. It's very strange it doesn't error in every pass through though, only some.

 

I tried upping the voltage to 2.85v, didn't make any difference, it also doesn't seem to make any difference at all whether or not I have Turbo and Performance Acceleration on or off. I really doubt this problem is connected to my power supply, its a brand new 420w and enermax is a high quality PS manufacturer, none of my other components besides the memory seem to be having any other problems either.

 

I apologize for the super long post but any help would be super appreciated Ram Guy! Also one last question, what would happen if I tried to just run my system at 2-3-4-6 with the errors, seeing as how there are so few. I havn't done any torture testing with prime95 yet but everything seems stable, I havn't been getting any more windows memory errors either? :confused:

Link to comment
Share on other sites

  • Corsair Employees

Please make sure that you have the latest BIOS for your MB and load Setup/optimized default settings, and try the following BIOS settings;

TwinX1024 or TwinX512-3200C2

Advanced/Jumper Free

AI over clocking: Manual

CPU Freq: 200

DRAM Clock: 400 MHz

Memory or Dim Reference voltage: 2.75 Volts

System performance: AUTO

AGP Voltage: Default *unless you have ATI (9200 or 9600) or NVIDIA (5200 or 5700) then 1.6 Volts suggested!*

Advanced/Chipset

Configure Dram timing by SPD: Disabled/User define

SDRAM CAS Latency: 2T

SDRAM RAS to CAS Delay (tRCD): 3T

SDRAM Row Precharge (tRP): 3T

SDRAM Active to Precharge Delay (tRAS): 6T

SDRAM Burst Length: 8

Peformance Acceleration Mode: Auto

USB Legacy Support: Disabled

All other settings should be set to default settings!

Also please make sure that you do not have any PCI cards installed on PCI slot# 4, since PCI slot# 4 is sharing an IRQ to the AGP card; this will cause conflict to the system as well. Then please test them one at a time with http://www.memtest.org and let’s make sure it's not some other issue! I would run the test for at least 2-3 passes to be sure!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...