Jump to content
Corsair Community

Dominator Platinum SPD and reporting issues


Jaghoose

Recommended Posts

Hi, first of all Hello to everyone on the forum :) I`m a proud owner of some Corsair products like CMD16GX4M2B3000C15 RAM, the H115i and most beautifull nad powerfull AX1500i. Unfortunatelly I have some strange issues with the RAM on my new PC build. All parts are not even a month old. Every time i boot my PC and try to run some monitoring programs such as CPU-Z, HWMonitor or Corsair Link I have problems with RAM detection. Corsair Link only some times shows the RAM, one time only one die, some times both. Very seldom it reports full information with the name of the ram including. HWMonitor shows proper information only form time to time. Normally it shows only one RAM without the name of the producer, only the speed. CPU-Z very often hangs on the "SPD" loading stage not showing full information of the RAM or not shownig them at all. Some times 3dmark in a summary score shows 0 MB of ram installed, some times only the total memory count and some times all is good. I can show you the screens and links to test summaries if you want. Please give me an advice what to do with the RAM. Should I RMA it ? With all that being said, I have to tell you that all runs with memtest86+ went OK. I`m little bit confused. Another question is that my RAM doesn`t have the Corsair Link connector but I`ve already searched the forum and found out that there are few versions of them.
Link to comment
Share on other sites

Every time i boot my PC and try to run some monitoring programs such as CPU-Z, HWMonitor or Corsair Link I have problems with RAM detection. Corsair Link only some times shows the RAM, one time only one die, some times both. Very seldom it reports full information with the name of the ram including.

 

I get the same issue on my system and it's caused by the CPUID SDK that comes with CL 4.5.0.55 still being ancient.

 

I expect the issue will go away once/if Corsair get their act together and ship a recent version of the CPUID SDK.

 

The CPUID SDK that comes with CL CL 4.5.0.55 is ancient and as a result my DIMMs and NVMe Disks still don't get reported. Why was such an old CPUID SDK released?
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...