Jump to content
Corsair Community

Discuss Link v4.5.0.55 here


Technobeard

Recommended Posts

  • Administrators

This will be the official discussion thread for Link v4.5.0.55.

 

If you'd like to report a bug, please respond to this thread in this format:

  1. Version of your Link software. NOTE: If you're not using v4.5.0.55, please install it and see if the bug has been fixed.
  2. What version of Windows you're using.
  3. Summary - One line / sentence explaining the issue
  4. Detailed description of the issue - This part can be as long as you want. It should be detailed enough so that we can clearly identify the issue and attempt to replicate it.
  5. Attach photos of the issue to the post that help #4.

 

02/10/2017 - Corsair Link Software Update Version 4.5.0.55

 

Changelog:

  • Added support for Lighting Node PRO
  • Added new product support for the CORSAIR Lighting Node PRO
  • Added Mimic color animation - display animation for selected lighting effect in the user interface
  • Fixed Vengeance LED modules when only one unit was controlled (Z170/Z270 motherboards only)
  • Condensed DRAM layout to display modules with the same SPD in one section.
  • Performance and stability improvements, minor bug fixes

Link to comment
Share on other sites

  • Replies 99
  • Created
  • Last Reply
  • Fixed Vengeance LED modules when only one unit was controlled (Z170/Z270 motherboards only)

  1. Failing to support Kaby Lake is outrageous :mad:. Looking at my earlier post all it takes to fix this is a later CPUIDSDK.dll so one should be attached to the first post in this thread.
  2. It's also totally failing to report the 2 x Corsair Vengeance LED modules, is this the intended fix? :rofl:
  3. One HDD + my NVMe SSD are still not reported. They are JBOD and not members of a CSMI RAID array. Fixed in 1.1.5.5 cpuidsdk.dll.
  4. Most of this all down to the CPUIDSDK being ancient. It's the same as came with CL 4.3.0.154 and even I am lost for works as to how incompetent this is.
  5. NZXT ship a far later CPUIDSDK that supports Kaby Lake and so should Corsair :bigeyes:.
  6. CL4 should display it's version number as I find many members fail to specify this or state "latest version" when posting.
  7. Eight temperatures should be reported rather than three. Fixed in 1.1.5.5 cpuidsdk.dll. I further feel CL4 should use meaningful names rather than the Temp #1 form it currently uses, same for the fan names.
  8. VBAT is not ~2.0 volts and this needs to be fixed. Fixed in 1.1.5.5 cpuidsdk.dll.
  9. I suspected many of these issues would be trivial for a competent software engineer to fix and that I should prove this, see http://forum.corsair.com/forums/showthread.php?p=891269.
  10. Reporting the same disk temperature twice is silly and causes confusion for some, see the 2nd #2 in http://forum.corsair.com/forums/showthread.php?p=890673
  11. From the SIV screen shot you should see all correctly reported.
  12. SIV can also control both DIMM LEDs based on a temperature, when will CL4 be able to do this?
  13. SIV can control the H110i + H110iGT pump speed using a Custom Curve, when will CL4 be able to do this?

The CPUID SDK that comes with CL CL 4.5.0.55 is ancient and as a result my DIMMs and NVMe Disks still don't get reported. Why was such an old CPUID SDK released?

 

The interlocking semantics are still incorrect and given I reported this on 09-Aug-2016 why? I also e-mailed the product manager who did not even reply to my e-mail. I suspect it's a one line change and can be tested using SIV 5.12 or later. It might have been half fixed, but when I open Configure Fan then pressed [Apply] a few times [Link Test] reported @ 00:29:50.894 seq 40 5 = CreateFile( \\?\usb#vid_1b1c&pid_0c02#7289_1.0#{3c5e1462-5695-4e18-876b-f3f3d08aaf18} ) Access is denied. so I expect the CL4 locking semantics are still incorrect in some of the CL4 code. See http://forum.corsair.com/forums/showthread.php?p=892949 for the details.

 

No fix for http://forum.corsair.com/forums/showthread.php?p=854759 is pathetic and as I specified before to fix -ve X and fail to fix -ve Y is incompetent!

 

How do I download new firmware into my CL Minis + H100i + H110iGT?

 

Have any of the following firmware bugs been addressed some of which have now been outstanding since 20-Nov-2014? If not on what date are they scheduled to be addressed please?

 

  1. http://forum.corsair.com/forums/showthread.php?t=134621 - Commander Mini will not control fans based on temp sensors
  2. http://forum.corsair.com/forums/showthread.php?p=757703 - Commander Mini + H100i + H80i fan mode register is not returned correctly.
  3. http://forum.corsair.com/forums/showthread.php?t=137364 - Commander Mini + RGB LEDs - Blinking Issue.
  4. http://forum.corsair.com/forums/showthread.php?p=754023 - 10,000 RPM Fans #1 - Corsair suspect it's a firmware bug of 16-Jan-2015.
  5. http://forum.corsair.com/forums/showthread.php?p=709734 - H100i + H80i incorrect colour if you use zero, use 255,1,1 rather than 255,0,0.
  6. http://forum.corsair.com/forums/showthread.php?p=855427 - H100i + H80i you can't use 1,1,1 rather than 0,0,0 as this is not black.
  7. http://forum.corsair.com/forums/showthread.php?p=837226 - CLCC support for 0% PWM or 0 RPM to stop the fans.
  8. http://forum.corsair.com/forums/showthread.php?p=893630 - H110i + H110iGT Custom mode does not work for the pump.

Some fixes appear to get promised, but then never seem to be released.

This is a known issue with a fix coming.

This was posted over 24 months ago on 02-Feb-2015 so I would have expected it to be fixed by now. On what date is the fix expected? On 03-Feb-2015 Corsair stated:

 

I believe it requires a firmware update to be corrected. It should be in the next Corsair Link drop, or the one after.

There have been at least 9 CL drops since then :(:.

 

So just so you guys know, we're aware of this bug, but because of the issues we've seen with H100i/H80i and the current version of C-Link, this has been backburnered to get more pressing problems fixed.

Posted on 03-Nov-2014, over 27 months ago.

 

If you'd like to report a bug, please respond to this thread.

I have done this for all the CL4 releases and Corsair have not responded to most of these posts. Why is this and why should I bother to report issues?

 

Here is an itemised list of issues which Corsair failed to respond to or address in a timely manor.

  1. http://forum.corsair.com/forums/showthread.php?p=871675 - CL 4.3.0.154 issues
  2. http://forum.corsair.com/forums/showthread.php?p=864149 - CL 4.2.4.25 issues
  3. http://forum.corsair.com/forums/showthread.php?p=851701 - CL 4.2.3.41 issues
  4. http://forum.corsair.com/forums/showthread.php?p=844974 - CL 4.2.2.27 issues - How do I change the TCP port
  5. http://forum.corsair.com/forums/showthread.php?p=841278 - CL 4.2.1.42 issues
  6. http://forum.corsair.com/forums/showthread.php?p=833499 - CL 4.2.0.162 issues
  7. http://forum.corsair.com/forums/showthread.php?p=892949 - CL4 locking semantics only half fixed.
  8. http://forum.corsair.com/forums/showthread.php?p=833532 - CL asking for a reboot when it should not
  9. http://forum.corsair.com/forums/showthread.php?p=837724 - CL4 using a massive amount of TCP transfers
  10. http://forum.corsair.com/forums/showthread.php?p=833695 - Silly driver package name
  11. http://forum.corsair.com/forums/showthread.php?p=833699 - Issues with > 32 CPUs
  12. http://forum.corsair.com/forums/showthread.php?p=834459 - CL4 does not support CSMI RAID
  13. http://forum.corsair.com/forums/showthread.php?p=836506 - CL4 does not support EC Sensors
  14. http://forum.corsair.com/forums/showthread.php?p=836736 - NVMe Disks are not Reported
  15. http://forum.corsair.com/forums/showthread.php?p=837364 - No support for the original Commander.
  16. http://forum.corsair.com/forums/showthread.php?p=845182 - BSOD caused by Corsair supplied AXi PSU/Asetek Cooler kernel mode driver
  17. http://forum.corsair.com/forums/showthread.php?p=845092 - 10,000 RPM Fans #2 - no reply
  18. http://forum.corsair.com/forums/showthread.php?p=853869 - 10,000 RPM Fans #3 - no reply
  19. http://forum.corsair.com/forums/showthread.php?p=854759 - To fix -ve X and fail to fix -ve Y is incompetent
  20. http://forum.corsair.com/forums/showthread.php?p=839550 - H100iV2 and H100iGTX have different firmware
  21. http://forum.corsair.com/forums/showthread.php?p=850509 - CL4 causing high DPC latencies.
  22. http://forum.corsair.com/forums/showthread.php?p=864164 - CL4 causing high DPC latencies after Corsair claim to have fixed it.
  23. http://forum.corsair.com/forums/showthread.php?p=837228 - CLCC support for 0% PWM or 0 RPM to stop the fans.

Note that some of the entries itemise up to 52 issues and I expect I reported other issues I could add to the list.

 

attachment.php?attachmentid=27732&stc=1&d=1486739024attachment.php?attachmentid=27737&stc=1&d=1486753239

attachment.php?attachmentid=27733&stc=1&d=1486739691

1821522626_CL4.5.0.55stilldoesnothaveKabyLakesupport.thumb.png.f6ca4da313eed18508637e1e5fd9cf56.png

RCK.thumb.png.ab122ddcb77c86edbfaf4300a9133a72.png

CPUIDSDK-1.1.5.3-that-comes-with-CAM.png.822484e7a3090e9f71d6ab95a7fef4a9.png

Link to comment
Share on other sites

  • Condensed DRAM layout to display modules with the same SPD in one section.

  1. Condensed DRAM layout is appropriate, but should be able to see the whole of BLT4G3D1869DT2TXRG in the title ;):.
  2. Only 7 of my 8 DIMMs are reported :mad:. Given we worked out what the issue was in August 2016 and fixed the CPUID SDK for a CL to be released 6 months later and not have the fix shows the CL4 team is incompetent.
  3. How did you decide on the ordering? Please can you explain why this is appropriate?
  4. I suspect the GPUs should also be condensed.
  5. The RM PSUs should be #1 and #2.
  6. As the DIMMs are associated with the CPUs DIMMs should be between the CPUs and GPUs.

attachment.php?attachmentid=27734&stc=1&d=1486740665

970475023_Only7of8DIMMsandorderingbettercouldbethe.thumb.png.20722db4309cc3ae18c93eb8f930ab89.png

Link to comment
Share on other sites

  • Condensed DRAM layout to display modules with the same SPD in one section.

 

I was wondering what is meant to happen when the DIMMs have different SPD information so ran CL 4.5.0.55 on a system with different DIMMs and got as below. There are two screen shots as the name oscillates between the two different DIMM makers :eek: which I was not expecting.

  1. This this the intended behaviour?
  2. If not what should it be?
  3. If the flashing is intentional the release notes should specify this as it's rather unusual.
  4. I suspect this has not been tested at all.
  5. The ordering is again unexpected.

 

attachment.php?attachmentid=27735&stc=1&d=1486745742attachment.php?attachmentid=27736&stc=1&d=1486745775

RXD-Micron.thumb.png.3b43b4f1c28b8efc26c3ea3df45accb4.png

RXD-Samsung.thumb.png.9c8a78afd24dd97c05bfbf6c644f813d.png

Link to comment
Share on other sites

  • Performance and stability improvements, minor bug fixes

[*]Performance and stability improvements, minor bug fixes ?????

 

You are wise to question if anything has been fixed as at least one trivial but important fix has either not been done or incorrectly done.

 

The interlocking semantics are still incorrect. I expect the fix is to interpose the OpenFile() and AcquireLock() calls to adhere to the specification at the top of page 4 of the Corsair Link Lock Library documentation that is AcquireLock() should be done before the OpenFile().

 

The interlocking semantics are still incorrect and given I reported this on 09-Aug-2016 why? I also e-mailed the product manager who did not even reply to my e-mail. I suspect it's a one line change and can be tested using SIV 5.12 which typically reports the issue in < 2 seconds.
Link to comment
Share on other sites

1. Version of your Link software: 4.5.0.55

2. What version of Windows you're using: Win10 64bit

3. Summary - One line / sentence explaining the issue:

Vengeance LED ram not working on Asus Z270E MOBO and 7700K

 

I used the previous version. At least one lane of the ram can be controlled and it worked fine. Now I updated CL there is no LED option at all and neither of the ram LEDs work.

attachment.php?attachmentid=27740&d=1486782803

CL.thumb.PNG.8173514aa1e1c3ae6e7c2dea5af7204b.PNG

Link to comment
Share on other sites

1. Corsair Link v4.5.0.55

2. Windows 10

3. Corsair Link does not recognize Intel Kaby Lake 7700k Processor temperature

4. The software does not show the mother board, cores and RAM. I tried with diffferent versions, reinstallation and i got the same result. It seems that the library cpuidsdk.dll is outdated.

5.

Captura.thumb.JPG.6afed776509d4aa2d0341a66990b203b.JPG

Link to comment
Share on other sites

4. The software does not show the mother board, cores and RAM. I tried with diffferent versions, reinstallation and i got the same result. It seems that the library cpuidsdk.dll is outdated.

 

You should specify which motherboard, better still add your full PC specs to your profile as specified in http://forum.corsair.com/forums/showthread.php?t=77167

 

A later cpuidsdk.dll will fix the Kaby Lake reporting, but may not address the motherboard. I advise you to check what HWM reports and if needed work with the HWM/CPUIDSDK developers to get support for your motherboard added to HWM. This will mean an even later cpuidsdk.dll will be able to report your motherboard.

Link to comment
Share on other sites

Vengeance LED ram not working on Asus Z270E MOBO and 7700K

 

I used the previous version. At least one lane of the ram can be controlled and it worked fine. Now I updated CL there is no LED option at all and neither of the ram LEDs work.

 

I get the same effect so it's useful to know it not just me that get's the issue.

 

2. It's also totally failing to report the 2 x Corsair Vengeance LED modules

 

I am wondering if it's just the LED revision 0x03 DIMMs that aren't reported. Please will you run my SIV utility and post the [sPD] + [sMB Bus] panels so I can check? On my system with revision 0x03 LEDs I get as below.

 

If anyone reading this has LED DIMMs that CL 4.5.0.55 does report please will you post the above two panels so I can try and deduce why.

 

BTW You should add yourl PC specs to your profile

 

attachment.php?attachmentid=27744&stc=1&d=1486796683

attachment.php?attachmentid=27743&stc=1&d=1486796608

1879339508_SMBBusCMU16GX4M2A2666C16Revision0x03.png.9670fcbc274e72ba979ece6986cf0650.png

1881211651_SPDSummaryCMU16GX4M2A2666C16Revision0x03.thumb.png.52583999aff8a456e20fa1b9c0022e22.png

Link to comment
Share on other sites

I don't have a bug to report, but would it be possible in future releases to be able to move where items are? As an example, my hard drive aren't in any order that I know. Even if it mimicked how windows listed my drives, I would be happy. I'd be even happier if I could drag and drop them where I want. Attached is an example. I'd like to move my 950 to the top, the 840 next, and the Seagate to the bottom. I am aware of the configure tab, but I'd rather see it here.

Untitled.png.3416b982b165e06f94d987241bb445a8.png

Link to comment
Share on other sites

I don't have a bug to report, but would it be possible in future releases to be able to move where items are?

 

I suspect this is the wrong solution and a better solution would be for CL4 to order the disks by drive letter and also display the drive letters.

 

After pondering this I feel that NVMe disks should always be before the others so have just changed SIV 5.16 to do this. The order is now NVMe -> CSMI RAID -> SATA -> USB. I feel CL4 should do the same, but don't hold you breath, especially for CSMI RAID support to be added.

 

Again displaying two temperatures is silly and only the highest one should be used. On the [home] tab this is not too confusing, but having 5 disk temperatures on [configure] when you only have 3 drives is.

Link to comment
Share on other sites

Performance and stability improvements, minor bug fixes

 

Looks like not all the stability issues have been addressed as CL 4.5.0.55 still crashes :(:. The system details are as per my PC specs.

 

I sent off the crash details and look forward to Microsoft informing me there is a solution ;):.

 

 

attachment.php?attachmentid=27767&stc=1&d=1486943936

262765900_CL4.5.0.55stillcrashes.thumb.png.b6aafa7be8ce70234e2fc254c92c68ed.png

Link to comment
Share on other sites

The CL 4.5.0.55 installer crashes on my Dell 7720 :rant2:.

 

System specs:

  1. Dell 7720
  2. Windows 7 x64 Ultimate V6.01 Build 7601 Service Pack 1 - fully updated
  3. Intel Core i7 Quad 3630QM (Ivy Bridge) 2.40GHz [E1]

 

I was installing it so I could answer a post without needing to use my desktop.

 

I thought it might work if I copied the files across, so I did and the GUI started OK, but nothing was reported. I then checked and the service had not been installed. Given this the GUI should have reported this as an error, but it totally failed to do this :(:.

 

As it happens this also happened to a user, see http://forum.corsair.com/forums/showthread.php?p=891137. The GUI failing to report it can't communicate with the service is rather poor and should be fixed :!:.

 

attachment.php?attachmentid=27778&stc=1&d=1487014160

attachment.php?attachmentid=27779&stc=1&d=1487014758

1986995007_CL4InstallercrashesonmyDell7720.png.d94d9117c9bf5f7be53b914d1de156b2.png

1926955536_CL4failedtoreporttheservicewasnotinstalled.thumb.png.7fa0929bd2438e5799161114c1f1e52d.png

Link to comment
Share on other sites

Hi All,

 

Its first time im posting here ; but here's an issue... i've 2 component ; H80iv2 & LED Vengeance ; I download this update because the official release version cant control my LED on Z270 Mobo ;

 

However this version totally disabled/missing LED control... :eek: was totally suprised by this....

 

My system spec as below

 

 

https://valid.x86.fr/wvmwdz

corsair.thumb.JPG.a565fe1d5273b61d1f0bea0af7a98c4c.JPG

Link to comment
Share on other sites

I come back here every now and then to see what lack of progress Corsair is making on Link... They are making negative progress, new hardware is coming out, and they fail to support it, while letting the issues with the old stuff remain.

 

I have become a walking dis-advertisement for Corsair. I've steered many customers away from their stuff at the stores, and even more friends. Lots of other good alternatives out there.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...