Jump to content
Corsair Community

H100i v2 LED Problem


mingl0280

Recommended Posts

There is no API, but in theory it would be possible to set the colour by directly sending messages to the device. Were you to do this you would need to exit CL4 first as otherwise it could replace what you set. First you would need to contact Corsair and ask for the CorsairLinkLockLibrary specification as you would obviously need to interlock the hardware access with other utilities.

 

The big problem you will have is knowing what to send to change the LED colour. I have tried and failed to reverse engineer this for Asetek LEDs which is why SIV can only control the fan + pump speeds.

Link to comment
Share on other sites

There is no API, but in theory it would be possible to set the colour by directly sending messages to the device. Were you to do this you would need to exit CL4 first as otherwise it could replace what you set. First you would need to contact Corsair and ask for the CorsairLinkLockLibrary specification as you would obviously need to interlock the hardware access with other utilities.

 

The big problem you will have is knowing what to send to change the LED colour. I have tried and failed to reverse engineer this for Asetek LEDs which is why SIV can only control the fan + pump speeds.

Yeah I tried to decompile Corsair Link 4 for some info and I found there could be something in the CorsairLink4.Server.exe, but I'm having trouble figure it out what command should be sent to there.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...