Jump to content
Corsair Community

Lighting Issues


rainshdw08

Recommended Posts

I bought this and a Logitech G910 because I wanted to feel them both in the real world, whichever was better, I'd keep.

 

I like the Corsair K70 much better, like the ways the keys sound and feel, like the letters on the keyboard are bigger and easier to read, like the wrist rest a ton better...pretty much like everything except...the software sucks, or it seems at least.

 

I initally plug in the Keyboard, both USB's, Keyboard lights up red. cool. The problem is, once I install CUE2, it crashes, freezes or bascially, won't light up at all in any fashion. I uninstalled CUE last night and the red came back onm the keyboard. I'm like ok, guess I'll try the 910 now...

 

I want to go back to the K70 because I'm pretty sure I like it better, install CUE2 again hoping it was just a glitch....nope. Same deal, I can play with it for about 5 min before the keyboard goes black. Except this time, the red lights don't come back even after I uninstall CUE2, I even rebooted and unplugged and keyboard and plugged it back in....black as night. wth?

 

I can still type with it....but I have a free keyboard that can do that.

 

I've been in and around google trying to find something, but all the answers are pretty vague.

 

Any thoughts here would be greatly appreciated!!!!!

Link to comment
Share on other sites

I bought this and a Logitech G910 because I wanted to feel them both in the real world, whichever was better, I'd keep.

 

I like the Corsair K70 much better, like the ways the keys sound and feel, like the letters on the keyboard are bigger and easier to read, like the wrist rest a ton better...pretty much like everything except...the software sucks, or it seems at least.

 

I initally plug in the Keyboard, both USB's, Keyboard lights up red. cool. The problem is, once I install CUE2, it crashes, freezes or bascially, won't light up at all in any fashion. I uninstalled CUE last night and the red came back onm the keyboard. I'm like ok, guess I'll try the 910 now...

 

I want to go back to the K70 because I'm pretty sure I like it better, install CUE2 again hoping it was just a glitch....nope. Same deal, I can play with it for about 5 min before the keyboard goes black. Except this time, the red lights don't come back even after I uninstall CUE2, I even rebooted and unplugged and keyboard and plugged it back in....black as night. wth?

 

I can still type with it....but I have a free keyboard that can do that.

 

I've been in and around google trying to find something, but all the answers are pretty vague.

 

Any thoughts here would be greatly appreciated!!!!!

 

To get your lighting back, hold ESC before plugging in the keyboard, wait a few sec, and let go.

 

Now as for CUE 2, have you tried other USB ports? Did you try CUE 1? There are also unofficial alternatives on other OSes, like ckb for Linux/Mac. See if it works fine there. I want to make sure this isn't the keyboard that is messed up, but the software.

Link to comment
Share on other sites

To get your lighting back, hold ESC before plugging in the keyboard, wait a few sec, and let go.

 

Now as for CUE 2, have you tried other USB ports? Did you try CUE 1? There are also unofficial alternatives on other OSes, like ckb for Linux/Mac. See if it works fine there. I want to make sure this isn't the keyboard that is messed up, but the software.

 

Sir, thanks for the help and lighting tip! Worked after I held in the ESC key while plugging in. Weird that you have to do that though.

 

as the the software, I'm installing CUE1 now...I'll let you know.

Link to comment
Share on other sites

Sir, thanks for the help and lighting tip! Worked after I held in the ESC key while plugging in. Weird that you have to do that though.

 

as the the software, I'm installing CUE1 now...I'll let you know.

 

To get your lighting back, hold ESC before plugging in the keyboard, wait a few sec, and let go.

 

Now as for CUE 2, have you tried other USB ports? Did you try CUE 1? There are also unofficial alternatives on other OSes, like ckb for Linux/Mac. See if it works fine there. I want to make sure this isn't the keyboard that is messed up, but the software.

 

Ok,

 

So I have CUE 1 installed, lasted about as long as CUE 2, about 2 min, then froze again. So I disconnected, held the ESC key and reconnected, but this time only the 1 USB with the the Keyboard symbol on it versus both (the one with the USB symbol on it also) Lasted a few min longer but ultimately I'm in the same boat. Its now stuck on one color from the fade option.

 

This is pretty frustrating. Like the keyboard better but the software sucks. I may return this one and get a non RGB on with Cherry Browns and save some money. Not sure what I'll do.

 

thoughts?

Link to comment
Share on other sites

Can you try the keyboard on another computer? Does it work fine?

You'll want to make sure Windows, USB Chipset drivers, BIOS, etc are all up to date.

 

Keyboard isn't the issue. it's the software. My entire system is completely new and everything is updated and in perfect working order.

 

If I don't install CUE1 or 2, the keyboard lights up red and everything works without issues, except the RGB lighting. As soon as i install CUE, it's toast, the RGB lighting, or any lighting on the keyboard for that matter.

 

My Logitech 910 I bought at the same time to compare to the K70 LUX has zero issues and its software and associated RGB lighting work great.

 

Problem is....I like the Cherry MX Brown keys on the K70 versus the Romer G switches of the 910.

Link to comment
Share on other sites

The Red+White lighting is the static profile which comes with the keyboard. This occurs when CUE is not running in Windows.

 

If the keyboard lighting goes dark when CUE is running, Then it sounds like it is working fine and all you need to do is assign a lighting effect to the keyboard.

 

I would suggest you take a look at the unofficial CUE 2 manual and see whether you can get the lighting working.

https://docs.google.com/document/d/18q4il6BLYNWfdifiPuOn-jrCwKphpar9b0Q7fK9YgRY/edit

Link to comment
Share on other sites

The Red+White lighting is the static profile which comes with the keyboard. This occurs when CUE is not running in Windows.

 

If the keyboard lighting goes dark when CUE is running, Then it sounds like it is working fine and all you need to do is assign a lighting effect to the keyboard.

 

I would suggest you take a look at the unofficial CUE 2 manual and see whether you can get the lighting working.

https://docs.google.com/document/d/18q4il6BLYNWfdifiPuOn-jrCwKphpar9b0Q7fK9YgRY/edit

 

:o: Why didn't I think of that...

Link to comment
Share on other sites

The Red+White lighting is the static profile which comes with the keyboard. This occurs when CUE is not running in Windows.

 

If the keyboard lighting goes dark when CUE is running, Then it sounds like it is working fine and all you need to do is assign a lighting effect to the keyboard.

 

I would suggest you take a look at the unofficial CUE 2 manual and see whether you can get the lighting working.

https://docs.google.com/document/d/18q4il6BLYNWfdifiPuOn-jrCwKphpar9b0Q7fK9YgRY/edit

 

Ok. Started a new profile. Seems to be working unlike before. EXCEPT....only in static mode can I actually use the keyboard. in RGB mode, not so much. Basically inoperable. But If I switch back to static mode, works great. thoughts on that?

 

Only other thing is...I tried to update the firmware but never got past 3%. after 15 min I tried to abort it but it said the keyboard would be inoperable. So I let it sit another 15 min. same result. said wth and stopped it anyway. Keyboard worked fine. Deleted CUE2 and reinstalled. Followed your directions and read the manual...created a new profile. everything seemed to be working fine. I could have a static and a RGB lighting effect in the Lighting Effects tab, as long as turned one off, I could basically do whatever I wanted. except actually type in RGB mode.

 

Note sure if I am still doing something wrong. I feel like a noob. grrr.

Link to comment
Share on other sites

Ok. Started a new profile. Seems to be working unlike before. EXCEPT....only in static mode can I actually use the keyboard. in RGB mode, not so much. Basically inoperable. But If I switch back to static mode, works great. thoughts on that?

 

Only other thing is...I tried to update the firmware but never got past 3%. after 15 min I tried to abort it but it said the keyboard would be inoperable. So I let it sit another 15 min. same result. said wth and stopped it anyway. Keyboard worked fine. Deleted CUE2 and reinstalled. Followed your directions and read the manual...created a new profile. everything seemed to be working fine. I could have a static and a RGB lighting effect in the Lighting Effects tab, as long as turned one off, I could basically do whatever I wanted. except actually type in RGB mode.

 

Note sure if I am still doing something wrong. I feel like a noob. grrr.

 

The Red+White lighting is the static profile which comes with the keyboard. This occurs when CUE is not running in Windows.

 

If the keyboard lighting goes dark when CUE is running, Then it sounds like it is working fine and all you need to do is assign a lighting effect to the keyboard.

 

I would suggest you take a look at the unofficial CUE 2 manual and see whether you can get the lighting working.

https://docs.google.com/document/d/18q4il6BLYNWfdifiPuOn-jrCwKphpar9b0Q7fK9YgRY/edit

 

Geeze...just as I think we are going ok and I'll have to figure it out later. Entire keyboard goes black. Works as I'm typing with it now. But everything in my new profile doesn't work. Tried deleting and creating new profile. Nothing. Still black. So frustrated here. Corsair's software sucks from where i'm looking at this. I can plug in my Logitech, which I dont like as much as this corsair...but their software is easy to use...and it works. every time.

Link to comment
Share on other sites

It sounds like a USB related issue instead e.g. Keyboard inoperable when running lighting effects, Fail to update firmware, etc.

 

Plug the keyboard into a Intel controlled USB port and see if that changes anything. Check your motherboard's user manual for more information. You will also want to make sure you have the latest USB chipset drivers installed.

 

• ASMedia® ASM1142 Chipset

- 1 x USB 3.1 Gen2 (SuperSpeed USB 10Gbps) port on the back panel

- 1 x USB 3.1 Gen2 (Super Speed USB 10Gbps) Type-C port on the back panel

• Intel® X99 Chipset

- 5 x USB 3.1 Gen1 (SuperSpeed USB) ports (1 internal Type-C port on the board, 4 ports available through the internal USB connectors)

- 8 x USB 2.0 (High-speed USB) ports (4 ports on the back panel, 4 ports available through the internal USB connectors)

• VIA VL805 Chipset

- 4 x USB 3.1 Gen1 (SuperSpeed USB) ports on the back panel

Source: MSI

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...