Jump to content
Corsair Community

Anyone Else -I Need to Repair CUE Every Reboot


Recommended Posts

CUE 2.8.70

 

Every reboot I see CUE in the tray, but it isn't active. Scimitar mouse is only working as standard mouse, UNTIL I go to control panel and use Repair.

 

This then goes through the process of installing again and says files were downloaded, yet when I go to CUE control panel it says the CUE software and firmware for Scimitar is up to date a;ways.

 

This is very annoying. Does anyone else have this issue or know how to fix it?

 

Devs, what's going on here?

 

Thanks!

Link to comment
Share on other sites

Same. New computer, new to Corsair and have had poor luck with the software. Given the integration of the software with the hardware this equates to poor luck over all with Corsair. Hope it gets ironed out as I expect such peripherals to simply work and not need CPR every time I go to use them.

 

 

Paul

Link to comment
Share on other sites

Same. New computer, new to Corsair and have had poor luck with the software. Given the integration of the software with the hardware this equates to poor luck over all with Corsair. Hope it gets ironed out as I expect such peripherals to simply work and not need CPR every time I go to use them.

 

 

Paul

Thanks Paul, at least I'n not alone. The worst thing is, I love the Scimitar mouse, but the software has been headaches. I think it's called CUE due to the fact it queues a headache every time I boot.

 

I hope there is a solution "out there" or maybe in the next update.

 

Dave

Link to comment
Share on other sites

I'm having the same issue, brand new computer, Windows 10 pro, no issues with anything else aside from CUE. I'd say every other boot, I get this message that I need to repair or that CUE can't load my presets and I have to reboot. The software is absolute trash and needs to be overhauled. Yesterday I made the decision to switch back to my Razer Blackwidow and Naga, never once had an issue with the Synapse software.
Link to comment
Share on other sites

  • 10 months later...

I have had this problem for over 2 years through 3 updates. I have tried every scenario you can find on these forums and it does not change. Clean install with updated everything possible, etc.

On top of that, I constantly lose my saved configurations and have to reload them. i had about 40 saved and slowly over about a month i was down to 4 or 5 and eventually 1. I can reload them and then watch them all dissappear 1 or 2 for each time i reload again.

Oddly, every once in a while I will have a run of 2 or 3 bootups where everything loads properly and my keys light up.

 

It sucks royally. When/If Black Widow makes a spill-proof keyboard like the K70, I'm out. This was Corsair's chance to win me over and get all my accessory business.

Link to comment
Share on other sites

  • 1 year later...
 Share

×
×
  • Create New...