Jump to content
Corsair Community

STRAFE Cherry Blue Non-RGB Refurbished keys unresponsive


nelmr

Recommended Posts

Hi, About a month ago I bought the refurbished STRAFE CH-9000529-NA/RF (Red backlight, blue switches) from Corsair's website (thought it was a good deal for <$50...). I issued a support ticket with corsair but being the weekend I won't hear form them for a while. So maybe you all could help if this is a common problem with an easy solution.

 

TL; DR: Keyboard used to work. Had it for a month. Today keys are unresponsive despite it being light up. I used to only used it on my desktop but the last time it was working was when I plugged it into my MacBook Pro. Now does not work on any computer.

 

--

 

It worked great until today. Two days ago I plugged it into my MacBook (was using windows 10 desktop) to work for a day using it on OSX. Everything was good.

 

The next day I plugged it back into my desktop but didn't use it. I did notice however that it was behaving differently. It had a wave-like lighting pattern I've never seen before (before it just stayed on all the time, or maybe I never caught it cycle into the wave display).

 

Today, I try logging into my computer and nothing happens. Keyboard doesn't work despite the lights being on. Plugged it back in the MacBook... lights come on, but keys don't work (including the backlight dimmer key). Booted into UEFI (bios) doesn't work. Booted into Ubuntu 16.04 (dual boot desktop). Again lights on, doesn't work. I have a 3rd computer I could try but I don't see the point at this point.

 

Also tried downloading software from Corsair, the latest CUE apparently is what they linked to (2.8.70) on the page for my keyboard. It did not detect my keyboard. However since installing I notice that in addition to the wave pattern it now cycle to full lit and then to alpha keys not being lit back to wave. Didn't notice this before either, but probably wasn't paying attention either.

 

I also tried different usb ports no different.

Link to comment
Share on other sites

I think your keyboard might have gone into demo mode. Try keeping ESC pressed while you plug in the keyboard, does that help?

 

Still doing the demo. I unplugged. Held esc, plugged in, let the esc button stay held for a few seconds, released, and then the lights turned off for a fraction of a second and back on. Unresponsive then the wave light show resumes a minute or so later.

 

UPDATE: I'm typing on the keyboard now :)

 

Once the keyboard when unresponse I plugged also in my other USB (rubber-dome) keyboard to type on. I tried the esc button power on a few times to no avail. Then I unplugged the rubber-dome keyboard form the from USB ports on my PC. Plugged the corsair into that slot with the esc held down, and the released. It worked. Then unplugged and plugged back into the original slot. Still working. This is really strange! But happy it works now.

 

Why the heck did the keyboard go (and stay) in demo mode? What causes this?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...