Jump to content
Corsair Community

Corsair M60 Problem


LairenyX

Recommended Posts

Hi,

 

I have a problem with my Corsair M60 mouse if anyone can any help. I tried to move the the pointer/cursor but the pointer/cursor doesn't move. It stays still. This is the problem. I bought this mouse in late 2011/early 2012 so the RMA period is long over.

 

Anyways, other symptoms, Window 10 usually recognize a device when plugged in and make a "blinging" sound, for an example, my Logitech 3D Pro Extreme joystick, my Corsair K60 Keyboard, a different mouse, however, when I plug in my Corsair M60 mouse, it doesn't make this "blinging" sound. Other symptom, when I plug in my mouse, the blue lights on my mouse turn on, so I guess it's getting power???, tried about 7 different USB port including 3.0 and 2.0, but no "blinging" sound. The last symptom is, of all the light being turned on on my mouse, the DPI light, the one with three stripe, is turned off. However, the 2 buttons flanking the DPI button, the square and single rectangle one does light up, just the 3 stripe DPI button is turned off. I plugged this mouse into 2 other computers and a laptop, and they either do not making this "blinging" sound, show any kind of recognition, or am I able to move the pointer/cursor on them either.

 

Any help would be appreciated on how to make my mouse move my cursor/mouse pointer again.

Link to comment
Share on other sites

I can't recall whether or not your mouse can be recovered using these steps in the thread below;

http://forum.corsair.com/v3/showthread.php?t=104856

 

If i recall correctly, If the legacy M90 had its top and bottom profile switch lit on and windows detected it as a bootloader device, You could recover it using the steps in the thread posted.

 

Hi, thanks for your answer. Unfortunately, I went to the device manager place, plugged in my M60 and only saw 2 "HID-Compliant mouse", with the M60 plugged in or not.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...