Jump to content
Corsair Community

Startup problem Gaming K95 Mechanical RGB brown


James48

Recommended Posts

Hello, I am a new member and I will do my best to avoid writing errors

 

I've a install problem with my new Corsair Gaming K95 Mechanical RGB Gaming Keyboard, Cherry MX Brown, received box today.

 

There are two types of installation programs to download version 2.8.70 and version 1.16.42 (I can use the latest version? I see the old Sail pictogram on my keyboard)

http://puu.sh/t3LTi/856d1e3401.png

 

I've tried both downloads, but there is no connection with the computer? Made connection with power cable to USB3, directly in the computer.

 

All the lights are burning but I can not type?

 

After start up message appears:

 

http://puu.sh/t3LJM/95ab7b18c5.jpg

 

Hope someone can help me?

 

Regards, James48

Link to comment
Share on other sites

I've tried an other USB port, now keyboard is working. Then installed newest Software version 2.8.70 again.

When pushing on Check for updates Software version 2.8.70, warning appear: Corsair Utility Engine detected an error during Software update check?

There might be a solution for?

 

James48

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...