Jump to content
Corsair Community

K55 RGB Keyboard not recognised by CUE


Recommended Posts

I've looked everywhere online [linus tech tips forums, corsair forums, etc.] and I've tried all of the following:

- updating CUE

- uninstalling keyboard HID drivers, unplugging + replugging, run CUE

- completely uninstalling + reinstalling CUE

- looking for K55 specific drivers


I could not find anywhere online about K55 Keyboard firmware installations.

The closest thing I found was Raptor K50 and I thought maybe k50 was just a series and it might work for a k55 but when I ran that firmware install for the Raptor K50 it said 'no k50 detected' so I'm out of luck on that.


Keyboard works fine as far as LEDs running default state and key strokes are inputting this message you are reading now just fine.


Note: These were the conditions upon when the computer was FIRST introduced to the new keyboard:

1. computer was off

2. sabre RGB mouse and k55 keyboard plugged into USB ports

3. booted PC with CUE set on "startup when windows starts"

4. after I got on desktop, I brought CUE to foreground and only Sabre RGB was recognized in the engine


Please direct me to some sort of method that I have not already tried. All I want to do is change the lighting I could care less about triggers/macros.

Link to comment
Share on other sites

  • 2 weeks later...
  • 11 months later...
  • 7 months later...

  • Create New...