Jump to content
Corsair Community

New K70 Rapidfire RGB, but CUE not working


Deutero

Recommended Posts

Hi All,

 

My wife just gifted me a K70 Rapidfire RGB, and I just plugged it in a few hours back. But when I downloaded & tried to run the Corsair Utility Engine I get a CUE.exe error - This application was unable to start correctly ... the (0xc000007b) error.

 

I read up on these forums and various others on updating Visual C++ Redistribute packages, Uninstalling CUE + the Keyboards mentioned in Device Manager, and then re-installing CUE, Ran a chkdsk, tried plugging it into USB 2.0, and I even tried turning it off & on again, but nothing seems to work.

 

Here's something I noticed, that hasn't been mentioned in any other post so far. I've got an Error 52 code on one of the System Devices in Device manager and that's for 'Corsair Bus'. Can somebody please help me out with this, I want to customize the keyboard so bad!

 

Screenshot of the error:

http://i68.tinypic.com/m7cc1w.png

 

Code 52:

Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

 

Please help me out here guys.

 

Thanks in Advance.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...