Jump to content
Corsair Community

Corsair Utility Engine causing mouse pointer to skip?


gamertaboo

Recommended Posts

What's up guys, so I've had my Corsair Sabre RGB Optical for a year now, and it's a great mouse, though I did have the scroll wheel's button die somehow, and when I finally got sick of waiting for Corsair's RMA to figure out what to do with me, I just took it apart and desoldered the switch, and then soldered in a good switch from an old mouse that I cannibalized, and it's worked perfect ever since. I also had a Corsair K70 keyboard with Cherry MX Browns with Red LED's for a year or so, but a few days ago I accidentally spilled a milkshake all over it.

 

So even though I immediately unplugged the K70 and ran it under warm water to rinse off the milkshake, and removed the buttons and let it dry for two days and it works fine now, this gave me the perfect excuse to upgrade and give the K70 to my 7 year old, who is also a gamer and has been gaming with a Logitech wireless kb/m set for a while (poor kid) lol. He loves the K70 by the way, huge difference between the Cherry MX Browns and those garbage dome switches... He may be getting my Sabre RGB too now...

 

Newegg had a great deal, the Corsair K95 RGB for $150, and I jumped on it immediately. Though I was very disappointed that my only options were Cherry MX Red or Brown, Browns are nice but I really wanted to try Blues. Anyways it came today, I plugged it in, and all seems well so far.

 

My problem is that I wanted to customize the RGB lights on the keyboard a tiny bit, and after installing Corsair Utility Engine, all of a sudden the second I launch CUE my mouse pointer skips all over the place when I move the mouse for some reason. If I move my mouse really slowly the pointer will track fine, but the second I move it even normal speed, the pointer skips all over and has what feels like lag. Very weird. The mouse also acts completely normal as long as CUE isn't running.

 

What's also weird is that I know I had CUE installed before and this wasn't an issue, because I customized my Sabre's RGBs a long time ago and they stay like that somehow, I'm guessing it's saved on the mouse or something? Not sure why I uninstalled CUE, but here we are....

 

Anyone know what's up? I'm going to try a reinstall of CUE and hope that works, and maybe updating firmware of the mouse and keyboard if I can manage it. Just really frustrating.

 

Specs if you need them...

 

MSI x99s SLI Plus

i7 5820k

PNY Anarchy 16GB 2800Mhz DDR4

MSI Gaming X GTX 1080

Intel 750 400GB NVMe PCIe SSD (C:)

Toshiba 5TB mechanical HDD (data/games/storage)

Acer Predator X34 @ 3440x1440 100Hz monitor

 

Windows 10 Home x64

Corsair Utility Engine 2.8.70

 

Thanks! I still love your stuff Corsair. :)

Link to comment
Share on other sites

So to update...

 

-Reinstalling CUE did nothing to help the problem.

-I tried to update Firmware, and there is an update for the mouse, but it hangs at 3% and won't budge no matter how long I leave it.

-Turning my polling rate from 1000 Hz to 500 Hz seems to have fixed the problem.

 

So I don't know why exactly but it was the polling rate I guess? Hope this helps someone, my mouse is back in business.

Link to comment
Share on other sites

Try this

If your firmware update is stuck at 3% or doesn't work at all the the following

 

1. Use a different USB port or configuration. Remember if you are using USB 2.0 plug the one with the arrows in first followed by the one with the keyboard.

2. Try running CUE in compatibility mode

2. Make sure that if you use USB 3, use Intel port and not 3rd party vendor like ASmedia.

3. Go to your Corsair installation folder in program files; right click on the Corsair folder and select Properties

4. Then select the Security tab

5. Click on Edit button

6. Make sure that Users and also Trusted Installer has full control

7. Restart CUE and update firmware.

 

What is the firmware on the mouse right now?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...