Jump to content
Corsair Community

Macros Not Working


MGD

Recommended Posts

I brought the M65 RGB Mouse and have installed CUE 2.7.78. When CUE starts it reports Macro not working properly try repair. On trying to add a Macro to the 'sniper' button the CUE locks up and exits. I have tried repair and installing various other versions but Macros will not work. I have also tried turning off windows driver signing but again it has no effect in allowing Macros.

This issue is listed elsewhere on these forums and in various other websites. Everything else about the mouse is fine including the DPI settings assigned to the mouse. But if i had known there was a Macro problem i would not have brought the mouse.

Can anyone provide a solution?

Link to comment
Share on other sites

Uninstall CUE, scan your registry with CCleaner or IObit. restart and reinstall CUE.

 

Saw your same suggestion on another post. Still i used Revo Unistaller to pick up the garbage but it could only find folders which it duly deleted. Tried CCleaner and of the 50 registry problems it found none were Corsair, CUE etc.

 

Reinstalled CUE and it reported again the Macro Error.

Link to comment
Share on other sites

Saw your same suggestion on another post. Still i used Revo Unistaller to pick up the garbage but it could only find folders which it duly deleted. Tried CCleaner and of the 50 registry problems it found none were Corsair, CUE etc.

 

Reinstalled CUE and it reported again the Macro Error.

 

Try manually searching for Corsair in the registry and deleting any entries pertaining to CUE. if you never installed another Corsair program you should be free to purge everything that comes up.

 

If you aren't comfortable performing this operation, i would contact Corsair Support to see if they have a better solution for you.

Link to comment
Share on other sites

I would hack the registry anyday but i have corsair link installed for my cooler. Also, as the corsair support ticket system seems to want every detail about me including inside leg measurement :p: i'll skip that at this moment in time.

I have however tried various installs and uninstalls with very little progress. One thing that is definitely true is that you have to restart the PC and get to the Boot menu to select the start without driver signature enforcement; this ensures that the Corsair Virtual HID driver is loaded. When loaded, this appears to stop the Macro error when starting CUE. (Ive stuck with CUE version 2.2.78 which incidentally throws an error when you check for updates but that's something for another post :D: ) Getting the virtual driver to load does not mean Macros work - well some do. The first Macro i tried was a simple 'LShift' key operation which just locked CUE up when pressing the mouse button assigned to the Macro. However, when using a Text to produce "asd" say in a Word Doc it works fine. So i can only assume there is something very complex in the way the Mouse/PC/CUE interfaces are interpreting the Macro. My current keyboard is a MS Sidewinder X4 which also allows Macros - maybe this is interfering? Who knows? I will continue to investigate and report findings. :cool:

Link to comment
Share on other sites

Ok. Tried just about everything including removing hidden drivers/hardware. Still cant get Macros to work. In fact I've given up - really sad and annoying they don't work; i will have to raise a ticket i suppose. :mad:
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...