Jump to content
Corsair Community

Corsair H110i suddenly not getting detected in Corsair link


Dienekes

Recommended Posts

Hello guys. As the title says, suddenly H110i pump stopped getting detected in corsair link. I bought it 2 months ago, and after 2 months of perfect functioning, this happened. I searched the web a lot, tried a lot of fixes from the forum, driver reinstalling etc. but nothing worked. I even tried unpluggng and replugging the usb link cable several times while the pc was on in case it would get fixed. Out of 10 times only 1 it worked, and when i tried to restart, it wouldnt show up again. As a last try, i formatted my computer... Which means i lost a whole day with this, and guess what. It still isnt getting detected. I even tried different usb ports. Funny thing is that the pump functions great. The cooling is perfect as it was. I just cant get the pump to show in link, therefore no rgb light control and the pump stuck in performance mode which means that i have an F-16 on my desk in terms of sound. Do you guys think this is a RMA? Sorry for the long post, and thanks for your time.
Link to comment
Share on other sites

  • 4 months later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...