Jump to content
Corsair Community

FYI .NET 4.5 Required


Recommended Posts

I did a fresh install of Windows 7 64b PRO onto a PCIe SSD.


I could not for the life of me get the newest version of Link installed(or any). It would go through all the hoops up until the progress bar of where it is supposed to install, pause a bit, and complete installation without progressing or installing anything.


I tried clearing anyhting that said Corsair on the computer, even on the other drive with windows still on it(Link was working fine). Reinstalling etc. I googled for hours. I tried older versions of Link. One version tried installing .NET web framework, but failed.


After that failure, I installed .Net 4.5(thats the version of .NET web Corsair Link 3.xx.xx tried to install) and Link installed fine. Everything works great


I wonder if Link assumed my PC had everything it needed to install itself on a Mint PC and just kept failing.


I just thought people should know that this helped me.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...