Jump to content
Corsair Community

K30 macro stopped working


Wombat1626865227

Recommended Posts

I've had my K30 keyboard for almost a year now without issues but very recently my macro keys suddenly no longer plays back the key presses it has been assigned. This is both for a recorded sequence of key presses and for simple single key presses.

 

I've tried reinstalling the configuration software, resetting all my macros and testing the macro keys with "hardware playback" switched on and off but still haven't managed to solve the issue.

 

The macro keys themselves work since I am able to use them to successfully record key presses. The problem is that the macro keys won't then playback those key presses after they have been assigned.

 

Any help would be appreciated, thanks for reading.

Link to comment
Share on other sites

With hardware playback, are you saving the profile to the K30?

 

For software playback to run, If i recall correctly, the program needs to run in the background. It could wither be the notifications tray or K30hid.exe.

 

Thanks for the reply.

 

I managed to fix the issue though I'm not sure how. Only thing that had changed is another system restart but I had already tried that twice before without success :sigh!:

 

Thanks for the help.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...