Jump to content
Corsair Community

Scimitar occasional cursor freeze/lag


Wiztard
 Share

Recommended Posts

For a few weeks now I've been having issues with the mouse cursor freezing up for about a second, and it happens about once every 15-30 minutes. I've tried the old and the new CUE, tried rolling back firmware etc and nothing seems to fix it.

 

I'm running the latest windows 10 build, I suspect the problem started after I installed the anniversary update but i can't be sure.

 

I've attached the CUE logs, can't figure out myself if the problem associates with any particular error message.

 

I appreciate the help!

2016-11-06T14-45-29.txt

2016-11-06T05-07-54.txt

Link to comment
Share on other sites

Thank you. It seems like the problem is related to this error message:

 

2016-11-09T20:55:32 I cue.dev: Mouse LED colors change failed.Device : Scimitar, Execution result = 1, result = 0, platform error code = 995.

 

I had just reinstalled CUE after checking the logs so i didn't realize that it was related since it only showed once in the log.

 

I remember this used to happen with an older firmware, and the solution was to just apply a static color. I will try this and see if it helps.

 

Still though if it's firmware related one would expect more people reporting the same issue?

Link to comment
Share on other sites

  • 3 weeks later...
You can find the CUE logs at %localappdata%\Corsair\CUE\logs

 

You might want to try a different USB port if your motherboard has a third party chipset for some USB ports.

 

 

I have done a restart and seems to happen a little less frequently, but it still happens from time to time.

 

Please find attached my logs. Any help to solve this would be welcome.

2016-11-28T11-32-26.txt

2016-11-28T12-43-13.txt

2016-11-28T13-33-45.txt

2016-11-28T13-36-57.txt

2016-11-28T13-43-09.txt

Link to comment
Share on other sites

Close CUE and try the mouse without any effects and macros running. Does the mouse still freeze?

 

What firmware is the Scimitar on?

 

I have closed the CUE and tried the mouse without any effects. Same result.

 

I have to make a small correction to the post above: so it happens if I lift a bit the mouse from the desk and place it down gently. It then freezes for a bit of time until i move it angrily. If i move it just gently it is stuck. But then again, this is not the only time it freezes.

 

How can I find the Scimitar firmware version? The CUE says "Software version 2.6.79".

Link to comment
Share on other sites

Hi

 

I have a Scimitar RGB i didn't use during 2 months.

And now i have exactly the same issue : cursor is freezed during 1 or 3 sec every 5 min.

I tried to use other USB port (2.0 => 3.0) : it happens less but it still happens.

 

note that i have as well a KG95 RGB

Link to comment
Share on other sites

  • 4 weeks later...

Thanks Wiztard for your answer.

I tried all USB (2.0, or 3.0) with the same issue.

I am on Win 7 64 but my son had the same issue on Win 10 with his scimitar !!

 

So now it is a shame but he didn't use his scimitar anymore.

Freezing in PvP it is not an option !!

Link to comment
Share on other sites

  • 1 month later...

Hi Just wanted to say i am having the same issues with the short second or so freeze every few minutes. I only got my SCIMITAR mouse a coouple of days ago and it is VERY noticeable and irritating when working in CAD software.

 

I tried ending the CUE process in task manager and it still happens. (and defeats the purpose of having an MMO mouse....)

 

I had noticed this with this lifting of the mouse as mentioned above. but as also mentioned it isn't the only cause.

 

I have also tried changing USB ports, but all of mine are USB 3 as far as i know and it doesn't seem to make a difference.

 

Log Files Below. Thanks in advance for any help or suggestions. (i really hope this is a bug that can be fixed :sigh!: )

2017-02-05T12-59-45.log

2017-02-05T21-30-03.log

2017-02-06T11-38-52.log

2017-02-06T11-41-18.log

2017-02-06T11-46-40.log

Link to comment
Share on other sites

  • 2 weeks later...

Just thought i would log in to give an update.

 

I am currently using it on my Asus Laptop (all usb3 ports i think) so swapping usb ports made no difference.

 

i am not sure if there has been a windows update or something, but this thing doesn't freeze anymore like it was when i first got it, so happy days. but it would still freeze if i lifted it even just the slightest bit off the surface i had it on. (any surface.) It's funny, but you don't realise how much you do that until it causes issues. lol.

 

i have just got home with a corsair MM300 mouse pad and it now works as i would expect a mouse like this to work. i can lift it quite a way off the surface of the mouse pad and it still works fine. No lag. no issues. so it would appear to be a surface issue.

 

just for the record i had tried it on my desk surface (office desk Beech "timber" laminate top, typical work/office type desk) when i first got it. i had tried it with paper of a few different types under it. and on our kitchen table which has white chalk paint on it. also a timber table we have, all with the same results as my OP.

 

I think this will end up being attached to my PC though as i travel a lot with my laptop and need something that works on any surface like my old mice did. Sorry Corsair, as much as i love the feel of the mouse and now that i am used to it, the number pad, i just don't want to have to add a mouse pad to my travel kit.

Link to comment
Share on other sites

  • 3 months later...
  • 11 months later...
I am also having this problem and it started yesterday. The mouse randomly freezes and it looks like it's being held in place by something because it jiggles at my input. This is a pretty new mouse so I'm not terribly happy about it. I'm attaching my logs.

2018-04-21T22-08-37.log

2018-04-23T06-10-46.log

2018-04-30T21-24-06.log

2018-05-05T21-32-00.log

2018-05-08T06-47-21.log

Link to comment
Share on other sites

 Share

×
×
  • Create New...