Jump to content
Corsair Community

My VOID Wireless headset does not charge to 100%


Frode789
 Share

Recommended Posts

So I got my new VOID Wireless headset today. I left it charging for while and the mic light was constant green, which should indicate 100%, so I turned it on. To my surprise it was only at 95%. So I connected it again and tried to charge it again for a few hours, but no matter what I do it is maxing at 95%. (according to CUE2) What is going on?

 

I did update the FW (39.02) with CUE. No difference.

Edited by Frode789
Link to comment
Share on other sites

As far as i know, the battery percentage is only an "indicator". If the battery last as long as it is supposed to, u dont need to worry.

 

Well I do expect in a brand new product they would get a simple thing as a battery indicator correct. And I'm not talking about the light indicator on the headset itself, I mean in CUE. Seems like some kind of bug to me.

Link to comment
Share on other sites

Well I do expect in a brand new product they would get a simple thing as a battery indicator correct. And I'm not talking about the light indicator on the headset itself, I mean in CUE. Seems like some kind of bug to me.

 

Yeah, i know what u mean mate. But thats what i have been told :sigh!:

Link to comment
Share on other sites

So I got my new VOID Wireless headset today. I left it charging for while and the mic light was constant green, which should indicate 100%, so I turned it on. To my surprise it was only at 95%. So I connected it again and tried to charge it again for a few hours, but no matter what I do it is maxing at 95%. (according to CUE2) What is going on?

 

I did update the FW (39.02) with CUE. No difference.

 

u use CUE2?

where to see battery stat on CUE2?

Link to comment
Share on other sites

 Share

×
×
  • Create New...