Jump to content
Corsair Community

Corsair Scimitar buttons not holding down


GrimZore
 Share

Recommended Posts

I just updated from the old version of CUE I deleted everything of the old CUE and did a fresh install to the new one and started setting everything up and I noticed when I tried push to talk in TeamSpeak that my button was not holding down when I hit it even thou I have it imitate holding key on which is not working any help would be nice.
Link to comment
Share on other sites

check your "recording devices" in your windows sound options. I had this issue when I had the scimitar and corsair void in teamspeak3. The issue was that my mouse3 hotkey button was not working at all and the weird thing about it was that teamspeak and windows recording devices showed no input from my mic when I talk. Even though teampseak and windows recording devices showed that my corsair mic was set as the default communication device for voice capture. The problem was that another device in my recording devices was still capturing sound "my Logitech c930 that had a built in mic" I had to simply disable the webcam. Oddly after that the teamspeak hotkey button worked and my icon lights up when I press the hotkey button and mic also works Edited by Tsuekasa
Link to comment
Share on other sites

I just updated from the old version of CUE I deleted everything of the old CUE and did a fresh install to the new one and started setting everything up and I noticed when I tried push to talk in TeamSpeak that my button was not holding down when I hit it even thou I have it imitate holding key on which is not working any help would be nice.

 

I also have this same issue and couldnt find a fix. Basically in "actions" where macros are I have my G12 macroed to press down numlock - button. But it only presses it down for a split second. If I were to make a macro that presses down and then releases, it holds the key down forever and im unable to unactivate push to talk

 

Anyone that could lend a hand? How do I wrote a propper macro command that makes my push to talk button activate as long as I hold down a key on mouse?

Link to comment
Share on other sites

Suddenly I'm having a similar issue where my macros (shift + number key) are sometimes not registering the shift in the keypress on my scimitar, so it just registers the number. This is very bad for MMOs because it's triggering the completely wrong skill. Possibly related to the issue is an error when I try to make CUE (2.0) check for updates. Any ideas?

 

Also, I own a Strafe keyboard and have started seeing random double keypresses lately as well. Is cue just spazzing or or something up with my hardware?

Link to comment
Share on other sites

I just updated from the old version of CUE I deleted everything of the old CUE and did a fresh install to the new one and started setting everything up and I noticed when I tried push to talk in TeamSpeak that my button was not holding down when I hit it even thou I have it imitate holding key on which is not working any help would be nice.

 

Make sure you are using remap key. Don't enable imitate holding. That option is when you want CUE to hold X for Y seconds. Which is not what you want.

Edited by Inheritance
Link to comment
Share on other sites

Suddenly I'm having a similar issue where my macros (shift + number key) are sometimes not registering the shift in the keypress on my scimitar, so it just registers the number. This is very bad for MMOs because it's triggering the completely wrong skill. Possibly related to the issue is an error when I try to make CUE (2.0) check for updates. Any ideas?

 

Also, I own a Strafe keyboard and have started seeing random double keypresses lately as well. Is cue just spazzing or or something up with my hardware?

 

how is the macro setup. as a shift + num or as a recorded macro?

Link to comment
Share on other sites

I also have this same issue and couldnt find a fix. Basically in "actions" where macros are I have my G12 macroed to press down numlock - button. But it only presses it down for a split second. If I were to make a macro that presses down and then releases, it holds the key down forever and im unable to unactivate push to talk

 

Anyone that could lend a hand? How do I wrote a propper macro command that makes my push to talk button activate as long as I hold down a key on mouse?

 

yea dont use num lock..... why would you use numlock out of all the options given. Go for f13-24, and use remap key to assign the button.

Link to comment
Share on other sites

Try a different USB port config, i would use ones that are directly controlled by the intel chipset, and try changing the polling rate.

 

Alright, I'll see if that helps. I left the polling rate at default and it's plugged into my usb passthrough on my keyboard right now

 

EDIT: The rear USB seemed to fix the issue as far as I've noticed. I left the polling rate at the default. I guess the passthrough makes the mouse wonky? Entirely unrelated, but I noticed my mouse would also stay lit up when the PC was fully shut down (but not while it was asleep.)

Edited by Jade Curtiss
Fixed issue
Link to comment
Share on other sites

Alright, I'll see if that helps. I left the polling rate at default and it's plugged into my usb passthrough on my keyboard right now

 

EDIT: The rear USB seemed to fix the issue as far as I've noticed. I left the polling rate at the default. I guess the passthrough makes the mouse wonky? Entirely unrelated, but I noticed my mouse would also stay lit up when the PC was fully shut down (but not while it was asleep.)

 

That is normal, the reason it lights up then your PC is shutdown is because most people want the usb port to provide power even when the PC is off.

Link to comment
Share on other sites

 Share

×
×
  • Create New...